GPG not fully supported yet?

Hello all,

I’m trying to use gpg under Haiku (R1/beta4) but so far I couldn’t get it to work. I searched through this forum and the bugtracker but couldn’t find any issues.

Generating keys does not work (for me). Pinentry and gnupg is installed. So instead I tried to import some existing keys (with - -batch) which worked. Importing without the batch option didn’t work. However since there is no password prompt (pinentry) decrypting and signing throws errors.

When trying to decrypt/sign files, gpg throws the error: Operation not allowed.

Does anybody else have these issues? If not, is there something I’m missing? Or a workaround?

Also is there a ticket on the bug tracker? If not I would open one if needed.

Haiku Version: R1/beta4 hrev56578+22 x86_64
GnuPG: 2.2.34

Kind regards,
Okabe

2 Likes

For ports you could add an issue at haikuports: GitHub - haikuports/haikuports: Software ports for the Haiku operating system.

I don’t think there are any open bug reports but it’s been on my TODO list for like 2 years. I think the last time I looked at the problem it seemed like gpg couldn’t find an appropriate file locking method on Haiku. It wanted to use hardlinks/flock/etc… which doesn’t work so well on Haiku.

I created a ticket on the bug tracker #18087, So if people have the same issue, they can refer to this ticket.

@Begasus I didn’t build gpg from haikuports, but if requested, I can also raise an issue on Github.

Update; the bug tracker is the wrong place to raise the issue → GPG is ported. I will open an issue on GitHub.

Sorry for the misunderstanding

1 Like

Just as an information for people having the same issue;

@korli fixed the issue and its working with hrev55608 (haiku - Haiku's main repository)

Did the following to verify the patch:

  • generate a new key pair
  • import an existing key
  • encrypt / decrypt files
  • sign files (works with git too!)

Pinentry is called correctly while importing secret keys, en/decryption and signing and everything works as expected!

Thanks so much for your extremly fast help and fix!

(I think the topic can be closed)

5 Likes