Gobe Productive 1.1.1

I was going through some CDs I had in my office and ran across a copy of Gobe Productive 1.1.1 which was released for BeOS R4 (both PowerPC and Intel versions). I was able to get the installer to work but when I try to launch the app itself it complains about a missing symbol _get_screen_bitmap_FP7BBitmapG5Rectb. Since it was targeting R4 and Haiku was targeting binary compatibility with R5 I guess that’s not totally unexpected.

I wanted to archive the disk and prove that the archive image works. The complication I have is that it is not a standard CD format but instead a BeFS disk on CD. I could mount the physical media in a VM. I was able to use dd to make a copy of the disk to an image file. I don’t have a means of writing the image file out though. Would someone here be interested in testing that the image can be used to make a disk, or even better test this under BeOS R4 or R5 to see if the same error pops up?


You can create a ticket in https://dev.haiku-os.org/. This probably can be easily fixed with code like:

status_t get_screen_bitmap(BBitmap *bmp, BRect rect)
	BScreen screen;
	return screen.ReadBitmap(bmp, false, &rect);
1 Like

Sure if an R4 targeted release is something that would qualify for it I’d be happy to. Since it was outside of what I thought the scope was I didn’t want to do that originally.

GobeProductive 2.0 is running fine on haiku but not free to use or open source

That’s good to know. I’m looking at this from a historical software preservation perspective though and to see if there is any interest in confirming the image integrity and that it runs somewhere.

Have you tried BeOS R5 Personal Edition? It is officially freeware and available here.

I tried a couple installs for BeOS 4.5 and 5 I found in archive.org but was not successful in getting a booting system. I’ll give that one a try.

First, it will probably not run on modern hardware, you need to use virtual machine (Qemu, VirtualBox, VMWare Player). Second, boot floppy image may be needed to run system (included in beos4linux.tar.gz).

Yes that was what I was going to attempt to do. I was going to do a barebones Linux install in a VM. Do you know if it is very particular about ext2 or if that was just the ext version at the time this was made so ext4 would work fine? I’m also hoping that floppy image is recognized by VirtualBox, the virtualization environment I use.

I’m pretty sure this .img file I made with dd is a bust though. I created a cue file similar to the one that came with the BeOS 4.5 install disk image. While Haiku can mount the 4.5 image it doesn’t mount/recognize this Gobe install disk image I created :(.

BeOS don’t recognize ext* if I am correct. File system of host OS don’t matter. BeOS (and Haiku) use its own file system BFS (Be File System).

BeOS is running fine on VirtualBox for me. RAW disk image (image.be) may need to be converted to format that VirtualBox recognize (VDI, VMDK, VHD).

Command to convert:

VBoxManage convertfromraw image.be image.vmdk --format VMDK

You say before:

Physical CD is mounted correctly but CD image is not?

Correct. If I bridge the physical CD-ROM to the VM and read directly from the disk the installer completed fine under Haiku. It was at runtime of the suite itself that the missing symbol error occurred. The problem is that the CD filesystem used was a BeFS one not a typical one so standard ISO handling tools aren’t happy with trying to copy/mount it. At least the way I was trying to use them. Maybe there is a trick…

IIRC, the CD might have some kind of BFS image on it and the issue with that is that the PowerPC BFS is big endian and BeOS x86 doesn’t know how to mount that. It depends on how your raw image is laid out, but you might find the PowerPC partition is causing the issue.

Edit - there did used to be an add-on called BigFS that could mount big endian BFS partitions - if you can locate it it might help you? It might just be that your dump has too much info and the OS can’t deal with it though. Have you tried looking at the raw low level format to see how the CD is laid out?

1 Like

You can make ZIP archive of CD contents. It should include BFS attributes. When taking CD image, it should be taken as HDD image, not ISO.

I have the Gobe cd, it is indeed a bfs file, but the image is freely available (unsure if it’s freeware or other these days) available on the web. The installer I have seen floating around different websites aswell. Is Gobe still around? I used productive a lot on BeOS for my writing purposes, but haven’t used it in decades.

No. Gobe ended around 2010. The latest software release is Gobe Productive v3.0.4 (2008, Win).

I’ve seen Gobe 2.0+ and the image of BeOS 5 Max which comes with it installed. This is a release before. If there are images of 1.1 too then I’ll be less concerned about making sure there is an archival image of it. It was a bundle option from when I bought BeOS. I can’t find my BeOS install CD but I did find this.