You can find many games with description on our knowledge base (only on the old one the english version - at the moment).

BeSly - the Haiku, BeOS and Zeta knowledge base

And here:

Gaming on Haiku

And no i does not play any game with wine, because there no tutorial about it and i does not know wich are running on haiku.


try to play Kigo
you can find it out with haikudepot.
:grin::grin::grin: you will enjoy yourself.

The only games I play are simple time wasters - xpat2 - xshisen - pysolfc - but I haven’t investigated whether they work or are available on Haiku.

ScummVM is being kept up to date, so many of the classics still work there :slight_smile:


Yeah, I’ve been playing Space Quest via ScummVM on Haiku last year. Great flashback into the late 80s/ early 90s :slight_smile:


Currently I like to play SYASokoban (as the name already says, a sokoban game) on Haiku. Which reminds me I still got to finish the recipe and submit it to HaikuPorts :wink:
I also enjoy @lelldorin `s Yabze, available from the BeSly repo.
And my own mastermind game Peggy. It’s available via pkgman/Haikudepot :wink:

That said I’d love to use the FlightGear flight simulator under Haiku, but I don’t think there’s any point trying to port it as long as we don’t have hardware 3d acceleration.

1 Like

I almost ported it awhile ago in which a backend dependency needed Haiku API integration to get proper visuals. Haiku improved a lot since then so I may revisit that…

Yet, many games are now provided through cloud gaming services using the web browsers - like Epiphany. Console games needing specific hardware are run on remote virtual servers and visualized through the web browser and on older hardware.

As for Haiku, nearly all arcade/home game console emulation provided by HaikuPorts:

  • ACE - Amstrad CPC / Amstrad Plus
  • FS-UAE: Amiga 4000(T) emulation
  • Dolphin - Gamecube / Wii
  • Libretro - Atari 2600->7800/800/Jaguar/Lynx/PSP/Sega DreamCast/etc
  • MAME - 3DO/Neo Geo/Arcade (Tekken 7, Shadow of the Tomb Raider)
  • Mupen64plus - Nintendo 64
  • SheepSaver - Mac OS 7.5 → Mac OS 9.0.4 PPC emulation
  • Wine - v7.9-1 (Haiku), Windows software (28,827 applications, AppDB)

Really amazing OS for PC/arcade/console gaming possibilities…

See: Gaming on Haiku


Beside the obvious 3D, perhaps two things could be improved.
Nowadays, USB sound cards and headsets integrating a sound chip seem frequent but, they are not working on Haiku.
Joysticks could have have a proper configuration tool and support more things.

1 Like

A while back I worked on a port of re3 and librw (Which are a re-implementation of RenderWare and GTA III / Vice City) so they could run on Haiku.

Here I leave my original post

It needed work to become playable, but you can clone the repo and play around with it a bit.

Haiku is such a lean/fast and easy to use system it could make a great “gaming os” if it were marketed that way to separate it from the pack.

There are a few emulators available on Haiku Depot but some of the most popular ones are not present, if there is one thing that I would hope for is somebody to port as many of the most popular standalone open source emulators to Haiku. This wiki shows almost all of the worthwhile emulators out there and which are the best for each system.

It would be cool to see projects like PCSX2, Xemu, Duckstation on Haiku or even the most recent PS4 emulators not that they can run much but to show Haiku is up to date so to speak.

Without Steam running on Haiku emulators are the best way to show off what Haiku can do from a gaming perspective.

1 Like

Without hardware acceleration, emulating something more powerful than PSX/Dreamcast would be dog slow on most of the systems.


You can theoretically run the Windows version of Steam on Haiku, as well. If it isn’t currently working, then we just need the Wine port and drivers to mature a little bit.

You can’t, steam definetely requires wow64, and our wine port doesn’t have any 32bit/multiarch support.

Multiarch support would be very welcome, but it’s not required in this case. Wine has its own WoW64 that can run in a pure 64-bit environment.

Which is experimental, and not available in any versions we ship. My point still stands.

As mentioned, remote/local “cloud” systems. You don’t need Steam or Wine.
The browser provides the access to any game console (emulated or direct (i.e. PS1->PS5/etc)) for gameplay (even online games like Raid: Shadow Legends and GTA Online). I’ve watched the growth of various LAN parties, arcade game emulators, and game consoles so you can do a lot ‘virtually’ while using low-cost hardware (but high-end visual hardware helps) - as well as ‘direct’ play.

I play OpenTTD on Windows 11 and Linux (Ubuntu). Currently I just play on Windows since OpenTTD 13.0 does not seem to work on Ubuntu (sound only, window or fullscreen game never shows up, can’t find the way to close it unless I restart).

I’ve just tried the Haiku port and it runs smoothly <3 but it seems that being a version behind (12.2) doesn’t leave any server to multiplayer games </3 I mean, it seems all (i mean ALL) servers have migrated to 13.0, because there are no servers available for me :frowning: Or is it something else?

If the interface allows to see server versions, perhaps can you check if there are still 12.2 servers while you play on linux or Windows. In this case, it could be a bug. Or maybe is it only listing servers hosted on same OS?

EDIT: After installing OpenTTD on my Haiku VM, servers of different versions (including 12.1 & 12.2) are listed but all are marked with a red dot.

I would love to see Space Girl working on Haiku.

Yes, sorry for the confusion. I mean, servers are listed. The red dot means they are unavailable. It’s not uncommon for servers to go offline, but all of them at the same time?

One of the possible causes for servers to appear listed with a red dot is version mismatch. That’s why I thought it had something to do with an outdated OpenTTD version.

It happened in Windows and Linux before that I found out that the reason was my creation being outdated, but they’re are always servers with outdated versions available. Now they are all unavailable.

Well, I’ll try again and see if it gets solved.