Force specific Resolution in VESA Driver


is there a way to force the VESA driver to use a specific resolution? I use a KVM Switch (DVI) and it seems that this one does not pass DDC information in a correct way, so i’m stuck with 1280x1024 as the maximum resolution even if my display is capable of 1920x1080. When using a direct connection, i can use the native resolution.

Additionally, is there a reason my system does not use the nvidia accelerant - i’m using a GeForce 8600 GT graphics card:

device Display controller (VGA compatible controller, VGA controller) [3|0|0]
vendor 10de: NVIDIA Corporation
device 0402: G84 [GeForce 8600 GT]

/boot/system/add-ons/accelerants> listimage | grep -i accel | grep -v grep
1294 /boot/system/add-ons/accelerants/vesa.accelerant 0xeac000 0xeb0000 0 0

The complete system log can be found here:


Hi ToraBora!

Your nvidia chipset doesn’t seem to be supported, the device id isn’t listed.

You should be able to enforce a VESA resolution by creating a file ~/config/settings/kernel/drivers/vesa and put in something like
mode 1920 1080 32
The last number is the bitmap depth.

Hope that helps also in case of your KVM.


i just tested this and unfortunately it did not work - the resolution stays at a maximum of 1280x1024 even if there’s another resolution in the config file.

Also did some other testing:

The KVMs and Graphics card work smooth in other OSes (tested Live Linux). Could this be a bug worth reporting and are there any tools to read the EDID information passed from the monitor back to the driver?


Question, how do these video cards work out if there is no KVM used?

PS. Just holding down the shift-key just before Haiku starts to boot will put you in safe mode.

the cards work as intended when not using a KVM switch. In the meantime i also tested a GeForce 7600 (which uses the nvidia accelerator) and this one also works as intended with the KVM attached.

To me it seems like some kind of bug. I will post a Bug report with the system.log of all different configurations attached.