Force ipv6 first


I’d like to go to a website which support ipv6 only, and doesn’t resolve correctly on ipv4 (for various reasons)

I can’t do this on webpositive or other browsers on haiku.

According to the standards, ipv6 should be resolved first:

How could I achieve that?

AFAIK ipv6 support is not complete in Haiku, so expect dragons.


Best strategy I read to attract new users. Let’s spread the word that we have dragons. :smiley:


Dragons are more sympathetic than some Dragonov !.. 8D

( Sorry for this poor pun - I could not skip it ! :)) )

Do you have IPv6 configured? (there is no autoconfiguration or DHCPv6)

The other main issue with IPv6 is that Haiku doesn’t support Path MTU discovery (this also affects IPv4, but is a bigger issue with IPv6, particularly if you are using a tunnel for IPv6 connectivity)

You need an interface with a valid IPv6 address, indeed.

I can only say for WebPositive, in its case, the address resolution is done with the AI_ADDRCONFIG flag, so IPv6 will not be tried if there is no configured IPv6 IP on network interfaces, as documented here: Ubuntu Manpage: getaddrinfo, freeaddrinfo, gai_strerror - network address and service translation

After you have manually set up an address, things should work, but I have not done much testing. I think the other problems in the IPv6 stack have been solved, but I didn’t try it myself recently (I guess I should figure out how to set my machine with an IPv6 address, it would be nice if it could do it automatically)

I thought I had ipv6 when I’ve looked in the ifconfig or with some ping, but indeed I’ve just tried again with ping6 and it says “network is unreachable”. I don’t know what data to enter to configure ipv6…

These tickets need to be resolved for ipv6 support:!closed&component=Network+%26+Internet%2FIPv6

1 Like