Fix mouse input with Haiku running in VirtualBox? [Solved]


I’m running Haiku in a VirtualBox VM and everything is fine, except that the mouse input is broken. When I move the mouse cursor into the VirtualBox/Haiku window, it always bounces back out. The mouse cursor inside Haiku does not move at all. Even installation was not possible that way (I tried with keyboard only, but failed). The only way I managed to solve this was by installing a second USB mouse on my PC and then use the “USB pass-through” feature of VirtualBox to mount that second mouse as a virtual USB device into the Haiku VM. This cannot be done with my “primary” mouse, because my host OS would no longer have a mouse! Even though this “two mice” solution kind of works, it is really cumbersome and inelegant…

Does anybody know for a better solution or workaround?

Thank you!

Try changing pointing device to “USB Tablet” in VM settings.

Thanks for your response! But I cannot find option “pointing device” in the VM settings.

Any suggestions?

Check here: Virtualizing Haiku in VirtualBox | Haiku Project

1 Like

Thank you for the link!

Setting input device to “USB Tablet” did the trick for me :partying_face: