Finally got Haiku booting!

:smiley:
I finally got haiku booting!
Before it would not boot (would just restart instantly.
This was due to a bad ram stick and my 4850X2 being really really weird (Burned card)

Booting off a quad core Phenom II (Soon to be Hexacore) 955 BE OC’ed to 300FSB x 12 with two 5770 running in crossfire mode, booting up Haiku (vesa mode ofcourse)

Reason I’m posting this is because for some weird reason, my mouse is really twitchy.
I thought it was because of me running Haiku in vesa mode, but after running chart flawless in 60 FPS, I suspect it’s an issue with the USB

Using a m4a79t motherboard, it detects Ethernet and sound also (which was very surprising :slight_smile: )

Catch you on the 10th of may :slight_smile:
I hope the mouse issue is fixed in the next release!

What do you mean by the mouse is “twitchy”? Does changing the mouse settings help?

After I install Haiku, one of the first thing I always do is put the mouse acceleration to zero and raise the speed just a little bit.

By the way, I think that you can increase the boot speed by tweaking with what the floppy drive does at boot, if you have one installed. I’ll update you later; mine goes from 7s boot to about 25s because some BIOS thing is set.

Well… I don’t exactly know the word I’m looking for (not an English person), but I think it’s something along the word “erratic mouse movement” ?
Changing the mouse settings doesn’t work.

It behaves like there’s a weak signal

And I don’t have a FDD :slight_smile:
It’s also set as “Disabled” in the bios :slight_smile:

I get the weird mouse too on one of my systems. I think it is most likely due to shared interupts. That’s one of the long-standing big things left to be done in Haiku for R1. It’s not going to be in Alpha 2, but is scheduled to make an appearance in the next release.

#5 on dev.haiku-os.org is the one to watch, I believe.
http://dev.haiku-os.org/ticket/5

Seems like it :slight_smile:

Grub2:
http://www.haikuzone.net/tips/installation/adding-haiku-grub2-ubuntu-9.10

starsseed, there are two different versions of Grub. The method described in your link shows how to make Haiku boot with Grub 0.97 & earlier. Grub 1.9x requires different method.

How did you add the entries to Grub 1.98?
I’m trying that with Linux Mint but it’s not working.
Could you please share the code for it.
Thanks in advance.

[quote=dreamtrip]How did you add the entries to Grub 1.98?
I’m trying that with Linux Mint but it’s not working.
Could you please share the code for it.
Thanks in advance.[/quote]

It’s here !
http://www.haiku-os.org/get-haiku/installation-guide