File_data broken in HaikuDepot?

I guess this might not be the right place to report this, but I’m having problems installing file_data-5.43-1-any from HaikuDepot. It downloads, but then I just get the error message:

 Fatal error occurred while installing package
 file_data: Failed to download package file_data ()

The problem is that this is a required dependency of file, which is a required dependency for lots of other software, like Bluefish and Toot. I’ve checked that my network is working, I’m able to install other things from HaikuDepot.

I’m running hrev57650 if that makes a difference.

Indeed, problems with haikuports packages should be reported here.

One thing that you can try is to wipe old transactions-* folders in /boot/system/packages/administrative. These contain incomplete downloads anyway.
Then check if the ‘new’ file_data package already exists in /boot/system/packages directory. In that case, move it momentarily on your desktop and try again. If it works, then you can safely put the one on your desktop to trash.

I had the same issue yesterday installing vim which depends on file data. My solution was to download the hpkg and install it manually

1 Like

Thanks for that workaround! Downloading the hpkg separately and installing it manually also worked for me. Though I did notice it seemed to have a dependency on itself (?) but that didn’t cause a problem when installing manually.

I’ve tried to report it on the haikuports Github, it’s issue 10243. First time reporting there - if there’s things I need to improve, I’m happy to learn for future reports.

You can check that by extracting the .PackageInfo file from the package. It contains descriptions, provides and dependencies. For this, you can use the package command in a terminal.
Then if it has a dependency on itself, perhaps something is wrong in the recipe. You can check that in Haikuports tree. Don’t ask me the folder…

Seems it produced a checksum error:

Checking local with installed and the one from the depot it shows the same:

/Opslag/haikuports/packages> sha256sum /boot/system/packages/file_data-5.43-1-any.hpkg
777d0c8238b783b96b541e6e5e2a910bdb7e4e1165f0f75c05909b2ef1403c1b  /boot/system/packages/file_data-5.43-1-any.hpkg
/Opslag/haikuports/packages> sha256sum /boot/home/Desktop/file_data-5.43-1-any.hpkg
5c2c2b4ddb83268c624097514b2a1a523b0a56be52562bd5a8580d1b775a7511  /boot/home/Desktop/file_data-5.43-1-any.hpkg

A revbump has been pushed for a rebuild, this hopefully fixes the issue.

Fixed :slight_smile:

1 Like