Few graphical glitches on start and other concerns (trying out Haiku Beta 3 on USB)


I just tried Haiku Beta 3 on my 32gb USB stick (flashed in balenaEtcher) and I have a few concerns.

On start Haiku set my resolution to 1024x768 while my monitor is 1280x1024. Not big of an issue actually, I just changed it in the Monitor settings and got my Haiku in full resolution. It also said something about VESA, so I guess we can count my NVIDIA GeForce 210 videocard as VESA-compatible for Haiku?

When I first tried opening the Teapot demo it worked fine (I even changed some parameters) until I closed it. When I closed it I got this glitch (sorry for screenshot quality):

It’s the teapot from that demo, but left as a glitch on my desktop. When I moved my cursor on it or touched it with the blue selection thingy it just disappears.

The first few minutes of trying Haiku weren’t really different: glitches and long waiting for software to load (I guess it’s just my USB stick being slow, not the Haiku itself).

Then I tried the Sandbox thing?.. Not sure how it actually should translate into English, in Russian locale it was named “Песочница”. Worked somewhat OK but also had graphical glitches when drawing. Video

After some time it started working like a charm, just teared a bit (which isn’t rare for UNIX-like systems working on NVIDIA).

The question is: is any of these issues actually caused by my NVIDIA videocard? Or is it just a Haiku thing and not related to my GPU brand?
Also, is there a fix or fixes for these? I really like how Haiku looks and feels if not counting these weird glitches and I may install it on my pc in the future.

My PC specs:

  • CPU: AMD Athlon II X4 640 (4) @ 3.00
  • GPU: NVIDIA GeForce 210
  • RAM: 4gb DDR2
  • Monitor: Philips 1280x1024~60Hz

may add more info if needed

Thanks in advance for any help!

It is not related to your graphics card, those are just bugs in GLTeapot/Playground.
You can try beta4 test candidate HELP WANTED: Haiku R1/beta4 boot & hardware testing! and see if those issues are still there.
Also please use Trac (https://dev.haiku-os.org) for bug reports.

At least Playground bug is known #12059 (Drawing issues for rounded rects (in Playgrounds demo)) – Haiku

Are the test release candidates still available?
I cannot download them!

1 Like

Glad to know it isn’t my graphics card. 'll check beta4 in a few days, thanks for the link (also, should I complete the survey after testing or should I just reply here as well?)

They are indeed still available, but the speed is very slow. You need to wait for a few minutes or so for it to load and start downloading.

UPD: nah, download just fails for some reason. It starts, goes to a few percents done and fails.

Okay, so I decided to try latest nightly build of Haiku and it worked… better! It was faster (which I think is because I didn’t change my locale this time) and the GLTeapot didn’t glitch (maybe it is fixed already?), so I’m not quite sure if I should report it or not. Should I?.. @Diver

Playground bug with rounded rects is still there, the 1024x768 resolution is still by default, screen tearing is there too.

A nice screenshot of my Live Haiku-nighly session:

If the Beta 4 test candidate be available for download I will test it as well. Currently the iso just fails to download after few percents done.


I’d say unless you can reproduce it there is no need to report that.

You are also welcome to report your hardware to our hardware database:

Hardware List: Complete Systems - Compatibility / Hardware - Haiku Community (haiku-os.org)

1 Like

Just did it with another nightly image (hrev 56637 x86_64)!
Didn’t find everything about my computer, I guess I’ll need to turn it off and check everything out physically to find out some info (like USB ports: I wrote some offhand information about those based on my memory, but the thing is that it is offhand and not 100% accurate). Or should I? I used inxi -Fxxxz output on my main machine (with Xubuntu) and listdev/listusb output while on Haiku, maybe there are more tools for it? Thanks.