Fatal issue with latest LibreOffice update?

I noticed that my LibreOffice got updated some days ago along with the rest of the system. After that, when I try to open a spreadsheet I had created and used with LibreOffice for months now I get this error:
The operation on /boot/home/Documents/Καινούριο σπίτι/Έξοδα.ods was started with an invalid parameter.
And does not open it.
I updated the system again just now (Haiku 64bit) just to check if it was any problem from Haiku side that got resolved. Nothing changed.
Anyone else experienced it? Where should I submit a bug report for this? It’s very serious. If nothing works I will need to boot to earlier state as workaround.

Clarification: does not work from deskbar’s recent documents OR from LibreOffice’s recent documents OR directly from open file.

Have you tried to rename the file And its parent folders to contain only ASCII characters?

Just tried that and yes it managed to open it. So, this is a recent regression because I haven’t changed the document’s path and name from the moment I created it.
BTW, Caligra just opened the original file without problem (with just some font rendering issues on the cells).

Could you try to use the same version of LibreOffice on Linux and try to open the original file there?

Yes, I will try to check it on Linux as soon as I find the time.

I dont think its a fatal problem, but 3rd party software bugs should be reported at HaikuPorts.