Failure to startup on new PC

Hi all - trying to set up a new (well -ish - from bits) PC with a Radeon graphics card (RX580) and it’s dying during setup - with a 4K monitor which probably doesn’t help. With beta 3 it just fails to initialise the monitor. With the nightly it dies trying to initialise the radeonhd accelerant. Is the 580 supported? If not does anyone know how I can get it booted in VESA mode in 4K?

Have you tried this? Troubleshooting | Haiku Project

1 Like

Thanks, but it doesn’t really help. I get as far using the fallback driver as the last rocket and then it just hangs (if I don’t use it it drops into the debugger).

If you can compile haiku yourself you could try this change:
https://review.haiku-os.org/c/haiku/+/4628

Sure, but is that not in the nightly?

It is not merged yet. See its status: “Active”

OK - I’ve tried that and not much difference. Even dropping the resolution to 1024x768 and the driver to VESA didn’t get me past the initial logon icons. Have you or anyone had any success in logging in via SSH or some old USB to serial dongle?

From Googling it looks like there might have been problems with the 580 - I’m just not sure how to get round them if you can’t log in.

Would be nice to open a ticket https://dev.haiku-os.org , even if the system does not boot to the desktop it will have created a syslog that can be used to try and investigate this.

Possibly this is https://dev.haiku-os.org/ticket/16463