Failure to download LibreOffice

It’s been a while since I’ve last downloaded and/or installed LibreOffice on Haiku, as it generally needs a lot of packages and slows down updates on the Nightly channel. But today, I decided to download it to try to see if I could help someone here.

And as there’s 113 packages to download, I think the server thinks it’s getting hammered by me. Each one zips through quickly (I have a fast connection) and proceeds to the next and the next without respite. I’ve tried installing LibreOffice three times through pkgman, and after zipping through 30 or 40 packages, it finally fails with “General system error” – and always on a different package.

So, I thought, maybe the graphical frontend (the HaikuDepot) would succeed. And here, I get the same result with a different package: “Fatal error occurred while installing package libreoffice.”


I can verify I’ve been connected throughout the install, so it’s not hardware. My thinking is that either packages are coming down too fast and the server halts the process (when I use softwareupdate on my Mac or apt on Debian, for instance, there’s a pause in between packages, but by comparison, I noticed Haiku downloads instantly), or that the cause of the error is otherwise an error in the Nightly build I’m using (hrev53567) itself. I can always test again on the Beta 1 release or a newer Nightly to see if this recurs, but whatever the reason, I thought I’d mention it here on the forum. I would open a bug report, but I haven’t yet isolated what causes the problem.

I have had something similar at different times with different packages, but I usually find that it works when I try again. Sometimes I get the message that an error occurred, only to find that the package installed quite happily.

I only use HaikuDepot and the Software Updater.