Failed to install on eee pc


Completely new to Haiku, I used a Haiku-usb to try on an old eee pc netbook.
It works from that usb, but after using the Installer and then quit tot reboot, I get:
Missing operating system.
Reboot and select proper boot device or insert boot media in selected boot device and press a key.

There’s no other OS installed on the drive, so why won’t it boot into Haiku?


maybe the partition isn’t set with the bootable / active flags, or the bootloader didn’t get installed…


Boot with the usb again all the way to desktop, open a teminal window and type the following:

writembr /dev/disk/ata/N/master/raw

Where N is either 1, 2 or 3… use the tab key to autocomplete the path, and then reboot. that should fix it.


Search and use bootman from the usb


Yes, thanks for pointing it out, fixed


In /dev/disk/ I don’t see ata, but do see floppy, scsi, usb and virtual as output.
I’m guessing scsi could be the target, since I see “0”?

I didn’t check wildman’s nor cosmogatokat’s suggestions yet…


Yes, scsi will be used in most modern hardware (using SATA and not parallel ATA).


writembr /dev/disk/scsi/0/master/raw
Can’t open /dev/disk/scsi/0/master/raw


Haven’t seen anything called bootman on the usb.


Look for BootManager in /boot/system/apps, bootman is what BeOS called it. the Haiku devs chose to change the name to BootManager confusing people attempting to help with boot problems.


Please open DriveSetup and take a screenshot of the window?


BootManager detected and started it from terminal.
In the GUI that popped up (I think that is the DriveSetup khallebal mentioned?) I selected the main HDD /dev/disk/scsi/0/0/0/raw

Next it suggested saving the MBR at /boot/home/config/settings/bootman/MBR

After that I powered off the netbook and started it without the usb and see:

Missing operation system.
Reboot and select proper Boot device or Insert Boot Media in selected Boot device and press a key


Screenshot of the DriveSetup


Anyway it looks ok! (Did not notice the Partition type! Linux is wrong!!!)

Try to make a USB-Stick first… and look if it works:


Perhaps I didn’t explain too well; the Haiku on usb-stick is working and booting.

What is not working is putting Haiku from the usb onto the HDD.


there, in partition type change it to beos IIRC it uses code EB, in your screenshot it says linux native


after some fiddling I thought I had it right, but after quitting DriveSetup there’s a pop up saying:
“The application
has encountered an error which prevents it from continuing.
Haiku will terminate the application and clean up.”

I clicked the option Save report.
Reboot didn’t boot into the HDD.

I don’t see how I can upload the report here.


It’s possible that writembr has a bug which effects some scsi and usb drives (i had a case where i couldn’t install the MBR on a sub srick using writembr), now to make things a bit clearer, delete the partition, and use DriveSetup to create a new one as a bfs type reinstall haiku and before you reboot, open a terminal and type the same line as above, if that still doesn’t work, launch Bootmanager and follow all the steps of the wizard (you seem to have skipped some steps the first time).


During install there was a General system error!
So I rebooted the usb and went to Bootmanager.
It says the HDD is incompatible even though it is formatted to Be File System.


You don’t give enough info on what you exactly did do.
Did you delete the partions on HDD and created a new one as a bfs “type”? your current partition is of linux type, that could be your problem even if it’s formated with bfs.