Ethernet port not showing up on network

Well, here i am using my old windows. Anyway, the 1st time I used haiku it worked fine and I really like the set-up. Then the next time i booted it up I couldn’t connect to the internet. I just decided to reboot it and install the network monitor on the toolbar. So I restarted it and I noticed my Ethernet port wasn’t there. It just said my wireless was hooked up. So i rebooted the computer using windows and looked to see if there were any similar problems and i found this

Please, Explain the terms in a way a teen who hasn’t upgraded his computer since 2005 would understand. (and uses windows where code isn’t strictly needed)

That worked. Thank you!

I have had haiku do this to me as well. Go to /boot/common/settings/network and delete the interfaces file. then re-boot. Your network might come back to life.

If you can reproduce this issue, please fill a bug issue on our Trac database ( and attach the “network” file to it before trashing it all.
This workaround is not a fix, the real issue should be tracked and fixed. Thanks for helping us doing it, eventually.

I filed a bug report.
Ticket #7475

Saw your ticket.
Thanks for taking some time to help us tracking this issue.

Let me know when this is fixed. Its turns out that the interface file keeps showing up, but it might be because my clock is ruined. Thanks.

The file shows up as soon as all your interfaces are not configured on automatic configuration (DHCP).

Well I finally fixed mine so it works. What I did was I looked at my ip address and everything in windows and wrote it down. Then I went to the interfaces file in haiku and opened the file in terminal and put in the settings for the ip, gateway,netmask, and default device. You all probably knew how to fix this but if there was the chance that you didn’t this is what I did and it works. Please tell me if I did this wrong or there is a better way. Thank you.