Errors Compiling AlephOne Engine

I’m having trouble getting the game engine, AlephOne, to compile. I downloaded the source code from:

The instructions say that for BeOS use:

make -f Makefile.BeOS install

When I do that I get the response:

Makefile.BeOS:208: *** target file `install' has both : and :: entries.  Stop.

Lines 207-208 in the file are:
INSTALLDIR = /boot/home/AlephOne
install: $(TARGET)

Next, I attempted to compile using the standard configure file, but it can’t seem to find SDL even though SDL 1.2.4 is installed from haikuware:

checking for sdl-config... /boot/common/bin/sdl-config
checking for SDL - version >= 1.2.0... no
*** Could not run SDL test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding SDL or finding the wrong
*** version of SDL. If it is not finding SDL, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ to point
*** to the installed location  Also, make sure you have run ldconfig if that
*** is required on your system
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error: You need SDL 1.2 to run Aleph One.

Could anyone tell me what I’m doing wrong? Thank you for your time!

You need to install libsdl.
To install these libraries you need haikuporter first:

wget -O- -q | sh -


haikuporter -i libsdl-1.2.15

Another note: you should install in /boot/apps/AlephOne not /boot/home/AlephOne, assuming that AlephOne has a GUI. Instead, if is a CLI you should install in /boot/common/bin.

Thanks for the help, I thought I was almost there after doing what you said. I got libsdl-1.2.15 port compiled and installed and got past it in the configure, but had another dependancy missing, I installed that from the ports collection, then another, then another, finally after installing boost it stopped recognizing SDL again and gave the same issue as before. Here is what I did:

haikuporter -i zziplib
haikuporter -i boehm-gc
setgcc gcc4
haikuporter -i boost-1.50.0

After the top two, I attempted configure and it was getting past SDL just fine, after the last it went back to the way it was before as above. I’m lost as to how boost could stop SDL from being recognized now. I tried to set the LD_LIBRARY_PATH environment variable to /boot/common/lib but that had no effect. SDL libraries still seem to be there, so I don’t know what happened!

Any idea what went wrong?

Assuming that you have also installed pkgconfig (haikuporter -i pkgconfig)

pkg-config --cflags --libs sdl

Here i obtain

-D_GNU_SOURCE=1 -I/boot/common/include/SDL  -L/boot/common/lib -lSDL 

Which means that SDL is correctly installed.

Let me know.

Very odd indeed then. I am posting a reply from my phone since I’m away from wifi, so I can’t post the output, but I ran the pkg-config command as you have it above and got the exact same output as you did. i also ran sdl-config --version and got 1.2.15. I have lot’s of experience compiling software on unix style systems and this is the first time I’ve seen something like this. Anything else i can try or do i need to start from square one?