Emmc in haiku, for low cost laptops

Small question about EMMC driver, is there in Haiku EMMC support? I have ASUS Vivobook and like another low cost laptops have soldered onboard emmc. Will Haiku in near future support this storage. thanks?

There is work in progress for an SD/MMC driver, which will eventually allow for this, but it’s not ready yet (it can detect the device and show its capacity, but not yet read and write sectors from it, which makes it not very useful so far).

thanks for answer, maybe in future, i think this cheap laptops will be here allways maybe in future will have more capacity and power.

Good day @PulkoMandy,

This work isn’t available for testing yet, right? I tried Beta 2 on the tablet and Drive Setup does not see the internal eMMc, so unable to install there.


The work on SD card and MMC support is merged in nightly builds. However I don’t have a device with eMMC I can test this on. If you have one, you can boot a current nightly on it and if the eMMC is not visible, open a ticket with a syslog.

There are likely some differences between SD and eMMC and it’s hard for me to write the code “blindfolded” with no hardware to test against.

1 Like

hi again i am here, i have
ASUS Vivobook EN203
umax 8wi plus
yoga 2 tablet 8 win8.1

i create usb stick and go test but i dont have in plan install becouse there i have func win, but i test and write here result

Good day @PulkoMandy,

Beta 2 boots without issues to desktop, but listusb and listdev don’t report anything. Nightlies don’t boot. The boot process stalls after loading cpu specific modules, thus no way to complete boot process. I have to get a clean pendrive as the one I’m using now has been through plenty of write ISO/wipe cycles.

I’ll try again activating onscreen debugging to see if anything comes out.

Actually, I didn’t realize this 2 in 1 had an eMMC until I tried to install Haiku. I’ll check the SD too. I’ll do labrat (slow rat though) and report on Trac.


listdev should at least list the eMMC controller. Otherwise the driver won’t find it either. Unless it’s not a PCI based eMMC controller, in which case, the MMC driver is probably not your problem, since it wouldn’t detect your hardware.