Dummy user building UpdateManager [solved, no-issue]

I fetched latest haiku source code, then skipped the build of the cross tools (I’m on a haiku 32 bit VM) and tried to build UpdateManager but faced some errors hard to understand (for me):

~> git clone https://review.haiku-os.org/haiku --depth=10
Clone in 'haiku' in corso...
remote: Counting objects: 27794, done
remote: Finding sources: 100% (27794/27794)
remote: Total 27794 (delta 1374), reused 14446 (delta 1374)
Ricezione degli oggetti: 100% (27794/27794), 47.20 MiB | 601.00 KiB/s, fatto.
Risoluzione dei delta: 100% (1374/1374), fatto.
Aggiornamento dei file in corso: 100% (25410/25410), fatto.
~> cd haiku
~/haiku> mkdir nuova_dir
~/haiku> cd nuova_dir/
~/haiku/nuova_dir> ../configure 
Configured successfully!
~/haiku/nuova_dir> jam UpdateManager
Starting build of type regular ... 
build-feature packages unavailable on x86_gcc2: webkit libdvdread libdvdnav libraw libavif 
build-feature packages unavailable on x86: gutenprint qrencode_kdl libdvdread libdvdnav libraw 
AddHaikuImagePackages: package icu not available! 
Asked for bios_ia32 target boot platform 
Unknown path to handle adding to image 
Asked for pxe_ia32 target boot platform 
Unknown path to handle adding to image 
don't know how to make UpdateManager
...found 1 target(s)...
...can't find 1 target(s)...

Do those messages mean I’m missing some packages? I promptly installed libraw and gutenprint (with _devel packages also) but nothing changed in the game, so I’m keen to think I am missing some steps.
Any suggestions?

I might be wrong, but I thing those messages are just telling you that the mentioned packages are just not available for that specific architecture (ie, no webkit build with gcc2, and gutenprint will uses the gcc2 version, for example). Edit: to be clearer: harmless info messages, in this case (as I understand it).

The “don’t know how to make UpdateManager” part of the message is the important one for you I think.

Are you trying to build “SoftwareUpdater”? if that’s the case, try with jam -jN SoftwareUpdater

Edit2: to be more clear… as jam says… there’s no target named “UpdateManager”, so that won’t work, unrelated to the rest of the (harmless) messages.

Try to install unavaible packages manually by:
pkgman update && pkgman install -y webkit_devel libdvdread libdvdread_devel libdvdnav libdvdnav_devel libavif libavif_devel qrencode_kdl qrencode_kdl_devel icu icu_devel
After installing those packages, try to rerun the UpdateManager with jam UpdateManager command.

Hope that helps.

Fool that I am, the software name given to jam needs to be the right one!
it is SoftwareUpdater (not UpdateManager) as reported in the heading part of the proper Jamfile (Application statement)
and case DOES matter.
[BTW jam downloads icu/icu_devel and everything it needs automatically]

1 Like

Yes, that’s what the last error message is saying:

don’t know how to make UpdateManager

The other messages should be cleaned up, they are due to problems in the way we manage packages in our jamfiles. They will always be there but will not cause other problems.