Disabling ACPI by default


I couldn’t start Haiku (hang on bootup), so I disabled acpi and could load Haiku.

I tried to make this permanent, by commenting the line related to ACPI on

It’s booting now, but the desktop remains blank, until I press for 1/2 second my powerbutton, then the desktop continue to load.

Is there an other place where I should disable ACPI?

Check out APM (power management) in the same file, maybe that will help.

Also do you gave a VESA file in the same folder? I don’t know why it helps but it does on some machines.

Sounds like bug 3999: dev.haiku-os.org/ticket/3999

I did that for APM, but it’s the same. I have also a vesa file with the correct settings.

I’ve made more tests:

  • Disable SMP
  • Disable APM
  • Disable ACPI

Then I can boot directly on the desktop.

But if I disable only APM and ACPI, then I need to press power button to load the desktop. And disabling only SMP is not better (I need to press power button), yet apm and acpi should already be disabled in the /boot/home/config/settings/kernel/drivers/kernel file. (Probably the shift key options when booting override the current options from this file)

I’ve also tried to disable SMP in the configuration file, so the 3 things where disabled like when disabling them from the boot menu, but it’s not working better.

On the previous Alpha 1, my computer [http://dev.haiku-os.org/attachment/ticket/4964/listdev_farvardin.txt] was booting directly on the desktop, without any problem. It’s a pity the acpi was enabled by default, if several computers can’t boot properly because of this. ACPI is not very useful on a livecd or liveusb. Poweruser could still enable this later, if it’s compatible for them.

Doubt this will help, your problem looks like a hard one to solve.

But about the VESA file. I had one computer that would not boot to the desktop if I defined too large a screen in the VESA file. The VESA file needed to be ‘640 480 32’ to work. Also don’t forget to hit enter afterwards in the text editor. If there is NO newline after the text the VESA file still does not work!

the ticket 3999 pointed out by 123king looks similar to the issue you are having too.

The quick fix for this ticket was:
“I just found out that disabling C1E (option AMD CPU C1E Support) on the BIOS allows the boot to proceed. So yes, some interrupt is being missed with C1E turned on.”

Go into your BIOS and turn off C1E and tell us if that fixes things for you.

I think the vesa file is correct. And I have the line break at the end of the file. It was made when I had the alpha 1, and it was working before, so I don’t think it’s related to this.

I didn’t tell about the issue 3999, I’ve tried this too because it sounds similar. But I can’t find anything related to C1E in my bios.

I did not think it was your problem. I only mentioned it because I have triple boot SSD. On two machine Alpha-R1 and Alpha-R2 boot fine but on an older machine Alpha-R2 would not boot until I found that mistake. The newer machines did not need the VESA file to boot, but the old AMD machine that I rescued from the dump did.

In less than 5 minutes I can probably find it on your online motherboard manual if you tell me your manufacturer & exact model for motherboard.

It is usually easier to search the pdf version of the manual than searching through the BIOS to find that setting.

Terribly sorry, I wanted to remove a spam post and seem to have deleted a regular post as well…
Can’t find a way to revert that. Could the author I so rudely censored re-post? :slight_smile: