Disable local APIC + Use fail-safe graphics driver to be able to boot on USB

Hello everyone,
I’m trying to install Haiku (R1/beta4) on my Dell precision m2800 laptop by booting on a USB flash drive. Unfortunately I don’t pass the Boot disk icon. I tried safe mode options one by one and disabling local APIC lead me allowed me to pass rocket icon but not boot. I had to activate fail-safe graphics driver to boot.


The forum can be quite active at times. Here it will be read by few people then quickly buried. It would be better to open a ticket on Trac for that.
This page should help you to know what infos are needed and what to join.

Welcome to the Haiku community @patriste !

You can make this permanent on your Haiku installation by following this quote from the troubleshooting guide:

“You can configure Haiku to always boot using the fail-safe video driver by enabling ‘fail_safe_video_mode’ in ~/config/settings/kernel/drivers/kernel”

Not sure if there is also an option to make the “disable local APIC” setting permanent.

There are some other entries you can put in that file that aren’t documented. I believe you can specify disable_apic true in ~/config/settings/kernel/drivers/kernel even though it isn’t listed as one of the examples. Only disable_ioapic is listed in that file but there are also options for apic, x2apic, and some other unrelated ones.


Thank everyone.
I found the origin of my problem. I use my laptop without battery. Thinking about trying with the battery I was surprised to see that my computer boot without problems.


That leaves me rather surprised that this made a difference to the boot process at all. But if it works → great :+1:

That happened only when I tried to boot with usb flash drive. Now that Haiku is installed on my ssd I can boot without battery.
Thank you.

1 Like