Digitizing my CD collection -> Album & song titles no longer show up

Dear all,

Finally, I am using Haiku as my main OS. Beta3 64Bit was installed on a Dell Optiplex 7010 that comes with an inbuilt CD/DVD drive. I’d like to use Haiku do digitize my CD collection, and it used to work like a charm:

I inserted the CD and - after a few seconds - was shown the disc’s icon in Tracker presenting the name of the album, as well as all individual track titles (after clicking on the aforementioned icon).

All of a sudden, this GREAT feature stopped working, Tracker now only shows “AudioCD” instead of the full album’s name. All of the tracks are just called “Track 01.wav”, “Track 02.wav”, etc.

I updated the system to the lastest (nightly) build of Haiku, but the problem persists.

So how can I make Haiku show the title of a CD again, after inserting the disc to the drive? Any ideas?

Many thanks in advance & best wishes,

Berny :slight_smile:

1 Like

Haiku now uses GNUDB for CD lookups since FreeDB shut down. B3 uses this already, and the change was some years ago so it’s not that.

I believe GNUDB now has a specific territorial block (Russia) - are you located there?

From the front page of gnudb.org:

To avoid breaking any software which is dependent on the service gnudb.gnudb.org is free and available via the cddbp, http and https protocol for non commercial use for an individual and not anonymous person.

Emphasis on “not anonymous” added.

Then… this page seems to indicate that the “email” field is mandatory, and AFAICT, /bin/cddb_lookup doesn’t seems to populate that one.

Maybe there lies the problem? (I never used that CDDB lookup feature, so… take what I say with a bucket of salt).

I use fre:ac (HaikuDepot) to rip my CD to mp3, a very good program to do that. This program take the data for the cd from the internet.

Hello & many thanks for your swift replies! I am based in Austria/Europe, so this shouldn’t be an issue.


I am using fre:ac, too. But it doesn’t show the album title or track names either. I also tried clicking on the “Database” → “Query CDDB dabase menu”, but nothing happens.

So to sum up my problem: I started digizing my CD collection using Beta3, and both album and track names were automatically shown after I inserted a disc. This worked for around 100 CDs, and then - all of a sudden - stopped showing any disc info apart from “AudioCD” on the Tracker window and “Track01.wav, etc.” inside the disc’s folder.

It’s interesting that, whenever I insert a disc that was previously digitized (i.e. from the first 100 or so), the album name as well as all track titles are shown.

This is VERY strange, indeed…

Is there any kind of log file I could send you guys?

Once again: Many thanks for your help & best regards,

Berny :slight_smile:

1 Like

There is a local cache, so this could explain that it works for some CDs, and not for others.

Is it possible that the service it’s using to get the CD info from limits queries per day (or month or just at all)? Sort of like those magazine sites that limit you to a certain number of free articles?