Difficulty Following Instruction to get ICH8 Audio Working

I keep finding over and over again, “It worked for me”, “Follow these instrucitons”, and none of it is working for me. So I need help figuring out what I’m doing wrong.
I am on a laptop which has ICH8 Family of HD Audio Controllers.
I have the “Could Not Find the Mixer” issue.
Based on these forums I tried to install OSS, and that made no difference.
Then I see several comments saying to blacklist the default audio driver then reinstall OSS.
So, I went to Disabling components of packages | Haiku Project and I am just lost.
According to Devices, the device/driver = bus_managers/pci/driver_v1
I found, “/boot/system/add-ons/kernel/bus_manager/pci” And I assume “driver_v1” is part of that file pci?
So, “Next step is to create a text file named ‘packages’ in /boot/system/settings…”
This is what I put in that text file:

Package haiku {
	EntryBlacklist {

I rebooted, still no sound. Reinstalled OSS, rebooted, still no sound.
I have no clue what I’m doing wrong. Is that packages file formatted correctly? I have no clue.

Welcome MGaddict!

The “packages” file is correct syntactically.
However, you would almost block the whole PCI bus, which you wouldn’t want. :slight_smile:

I’m not sure where Devices gets the “bus_managers/pci/driver_v1”, but that info isn’t the driver responsible for your audio hardware. Devices says “Driver used: unknown”, because that info isn’t implemented yet AFAIK.

What you need is to do a “listdev” in Terminal and find the output for your “Multimedia controller”. There you see the vendor and device ID.
I assume your device would be covered by the HDA driver.

When you do a “listimage | grep hda” in Terminal, you find if the driver is used.

If you now wanted to block it, you put add-ons/kernel/drivers/dev/audio/hmulti/hda add-ons/kernel/drivers/bin/hda in your “packages” file.

In any case, you should file a ticket at the bugtracker including all this info, plus your syslog.


The correct content is:

Package haiku  {
	EntryBlacklist {

That’s how i have it in my system and oss is working on 64 bit, but for some reason it stopped working on 32 bit, i haven’t had time to investigate it yet.


Some audio I/O paths are incorrectly set on Haiku on cold boot. Booting into Win/Linux/OSX first, then rebooting into Haiku gets working audio, sometimes through laptop speakers, on some PC’s on headphone audio only. There are a thousand ways to route audio out from the D/A mixer, and unless a dev has the exact same hardware, it’s hit/miss if its routed correctly. Linux just has larger user base so the correct routing options for your specific motherboard are identified sooner. As Haiku user base grows, these routing mismatches should eventually disappear.


Thank you.
I’m kind of glad whatever I had in the packages file didn’t work, because disabling the entire pci bus would have probably made this quite unusable.

Before making the change to the packages file, listimage showed this:
3594 0xffffffff8031c000 0xffffffff80329000 0 0 /boot/system/add-ons/kernel/drivers/dev/audio/hmulti/hda

Now it shows this:
TEAM 1405 (/bin/grep --color=auto hda):

This doesn’t seemed to have changed the sound working, I still see “could not find the sound mixer” from the volume control.

I wanted to make sure I tried whatever steps were out there before filing a bug report. My own green ignorance isn’t a bug I think the developers need to solve. However, I do believe this really is a bug at this point. Thank you again.

I tried both your entry and humdinger’s entry and both result in the same output of listimage | grep hda:
TEAM 1405 (/bin/grep --color=auto hda):
So it looks like that dissabled the hda driver however, sound still isn’t working with OSS installed.
But thank you so very much.

You’re bringing up an interesting idea. I could not figure out how to install Haiku directly onto this laptop. It’s an old General Dynamics Go Book VR-2. (Core 2 Duo, 4GB RAM, very non-standard everything as it was designed for military use.) I had to dissable IO-APIC in order to get anywhere. The live image then just complains that it can’t find anything bootable about half-way through booting and typing co into the console doesn’t do anything.
What I ended up doing, was installing Haiku on the SSD using another computer, then transfering the SSD into this one which worked great.
Now, becuase that other computer obviously has different hardware, I wonder if it miss-configured something.
This laptop doesn’t duel-boot anyhing. Haiku is is only OS I’ve managed to boot besides Windows XP or Windows 7. Since neither of those are supported, I just deleted it. Aside from the sound, Haiku runs so much smoother on this laptop than Windows ever did. I’m trying to get sound working in hopes of making this usable again.

you might want to look into a bios replacement

Haiku doesn’t do hardware-specific instalaltion (eg. installing or not installing drivers according to the hw available at install time), and it is also do a stateless install (eg. it doesn’t configure hw in install time).

So consider to get a supported hw instead of this milspec Quasimodo.

1 Like

I think I took a wrong turn when drill-down-navigating for the right file. :slight_smile:
It’d be nice to have an indication for symbolic links when there…

I edited my original comment accordingly.


This is likely related to your problems with hardware. Disabling this leaves the OS somewhat crippled in terms of what it can do with various I/O features including interrupts, which may leave it unable to use some hardware entirely.