Copyattr Error

I’ve been able to build Haiku on Linux without issues, but having some trouble getting it to build on BeOS.

I’m building Haiku on BeOS Dev Ed 1.1 (R5/netserver).

Installed & using the latest & proper GCC & Jam versions.

I get an error during the build.

Error is:
The application:

/bin/copyattr --data src/bin/gdb/bfd/config-x86/bfd-in3.h gener

has encountered an error which prevents it from continuing. …

How can I get Haiku to compile on BeOS?
Is there a newer copyattr binary I can install?
Would installing a different Tracker work better?

Any ideas?

Update #1
I installed latest OpenTracker. Still same error.

When I got the error again, I went into debug mode & saw:
Invalid opcode occurred

So, I think it doesn’t like my AMD processor. Kernel may not be patched to handle AMD cpus properly? (I’m running through VMWARE & given the OS 384MB of RAM to work with).

I was able to get it working (compile/jam).

I replaced copyattr with the one from my Zeta partition. (copyattr from Dev Ed 1.1 is not updated for AMD cpus).

Building worked afterwards, but I couldn’t make a haiku image, because a few targets did not build (for some reason - which I’ll have to look into).

Also, it took a long time to build in Dev Ed 1.1 through VmWare (4 hours or so) on an Athlon XP @ 2Ghz.

I may try BeOS Max (netserver) instead & see if that goes better.

Crazy, how Linux was easier to build Haiku on.

I installed Dano natively on an Athlon XP system with 512 MB RAM.

Copyattr did not give an error when jamming. Worked great.

So, either it was VmWare or me giving the Virtual Machine only 384MB RAM that caused copyattr to crash. One or the other.

copyattr is a program which copies BeOS’ files’ attributes. I think it’s not part of OpenTracker.

I used BeOS dev edition 1.1 for a long time, it was stable but not everything was tested to the max I believe.

Still an interesting experience to read!