Compiling python 2.7.5

in trying to compile python 2.7.5 in haiku_r1a4, i can’t seem to get around an error along the lines of “cannot find -lm”. from what i’ve read elsewhere, libm is part of libroot in haiku and so blanking out any reference to -lm should work. tried it to no avail. in another thread about the same library, a couple of edits were recommended – in and tried those, same result. i’m kind of at a loss – there are configure options accounting for the library in question, but i don’t know what to put in there. current python would be kinda nice to have, and it seems everything needed to compile is in place, i just don’t know how to tell this machine to do things.

managed to build and install with configure flags --prefix=/boot/apps/python_2.7.5 --disable-ipv6 --with-libm=" "

there’s a fat list of modules that failed to build, however.

All our ported software is built using the recipes at haikuports:

You can look at the “recipe” file where you can find the command used to build, and in the patches/ folder there are the patches we did for each version. If you want an updated python in Haiku, the best way is to contribute an updated recipe and patch to haikuports. This way, we can easily build a new package and include it into the package depot.

Even if you don’t want to do that, the patches may have some useful information on how we got things to build.

cool, thanks for the link and the tip. the patch and recipe are quite a bit more involved than my little configure flags – how do i get that all running with a machine that doesn’t get online? also, at what point does this all stop looking like heiroglyphics?