(CLOSED)Webpositive not working after update to Hrev 216

Pl. See the screenshot…anything to do with update of haikuwebkig 1.8?

Great picture! :stuck_out_tongue:

Yes. The buildbot is currently choking on the latest webkit build. Once it’s digested the new recipe, it can build the new webkit package that the latest WebPositive has ordered.


Yes, Web+ builds against haikuwebkit 1.7. still, but you have a newer incompatible version installed.

The haikuwebkit 1.8.1 build has been fixed, and the builders should be fixed now aswell (including a commit that will make gerrit work, a fix in our netservices)

Once haikuwebkit 1.8.1 is available in the repository the haiku build will be switched over to that, so that webpositive uses this newer version, that should resolve the issue.

If you require a workaround you can install haikuwebkit 1.7.1 from an earlier state.

1 Like

Can only make out a couple letters (maybe) from that photo. Not sure if that means I need new glasses or monitor. :laughing:

But yes, Web+ is broken at the moment like what the others said. Maybe update in a couple days or so? Should hopefully be working again by then.

1 Like


Miss the symbol : _ZN8BWebView…

That’s the error message.

Otter browser work instead…But have a blank screen on this Forum.

1 Like

Like @Kitsune64 I’ve tried to quickly recreate the screenshot so everyone can read it using Preview on my Mac and alert in Terminal in a Haiku VM (@san2ban, Haiku has a screenshot tool at /boot/system/apps/Screenshot that can be opened from Terminal or some PC keyboards have a PrtScr key). I tried with this but the characters in between 88 or 8BWebView C and (1BUrlContext) I couldn’t really tell for sure, so here’s a quick guess everyone



This has been reported, see ticket … https://dev.haiku-os.org/ticket/17035

The symbol is _ZN8BWebViewC1EPKcP11BUrlContext which demangles to BWebView::BWebView(char const*, BUrlContext*).

1 Like

Fixed in r1beta3 and hrev55218 respectively.

Please test the new Web+ with haikuwebkit 1.8.1 and report bugs to trac. :)


Just ran pkgman full sync, it updated the webkit to 1.8.1 (didn’t see an update to WebPositive but that could have been done yesterday, still the same missing symbol here (R1B3 hev55181+28 64bit))

1 Like

You need beta3+32 or so, Not sure whether that has been build yet.

1 Like

pkgman full-sync didn’t update after +28 (so far) :slight_smile: so will use Otter for now

1 Like

The R1/beta3 and master package repositories should have the needed haiku*.hpkg haikuwebkit* package updates to address this issue now.

We’re trying to push this update through at the last minute to avoid this pain for R1/beta3 users once it comes out officially :slight_smile:

1 Like

Ran pkgman full-sync earlier, updated to +32 so everything is working fine again, thanks! :slight_smile:

1 Like

For the ones that are on the nightly builds, the WebPositive issue is fixed on hrev55218.

1 Like

Can you login with Web+ and review/modify/approve/delete tickets within Gerrit 3.2?

If you build with this commit then you should be able to. It’s in both branches now.


Webpositive works now after update to hrev218…but forums are not displayed properly…scrolling is horrible…contents take ages to be displayed while scrolling

Not happy …webpositive was better earlier…scrolling is horrible now…contents take a long time to display

Please report issues on the bugtracker. This release has been delayed a while because of api changes in the nightly branch, thus a bit bumpy, but we can’t realy fix bugs without specifics, on the bugtracker.