[Closed} Mail application: Error

Positive things first. Beam works…I am happy
But, I prefer native application. Hell bent on seeing that Mail works

I have configured for POP3. Error message as mentioned below pops up when I check for new Email
"sanjaymr@disroot.org Error while connecting to server disroot.org:993: Address family not supported by protocol family [Sun Aug 20 15:13:14 2023] " ( parentheses I have put)

In Mail application, there is no provision for entering port number, protocol. In the documentation guide for Mail, it is wrtitten as below
First is the SMTP server address for outgoing mails. As with the incoming server before, you can use a specific port if needed, e.g. mail.your-provider.org:1200.
Hence, I have put port number 993…but I get above error…
At least via POP3, we get this error. When I try to connect via IMAP, there is no error message…nothing happens…cannot make out what is happening
Pl. guide what values should be entered and where to enter the settings on Mail for IMAP/ POP3/ port protocol

You are using the wrong port, please configure this how disroot sais and then report back.

port 995 did not work…so tried 993…i have seen the details for disroot.org…get the same error for port 995, 993
POP3 is 995…i get the same error…

IMAP…no response

Have you explicitly enabled TLS?

unencrypted mail checking does not work for disroot.

Yes… I have enabled SSL for IMAP IMAP did not work
For POP3 also I have enabled SSL…

For SMTP, disroot.org recommends STARTTLS…since STARTTLS option does not show in Mail, I have set it to Encrypted…(this was suggested on the web in some forum for somebody’s issues)

For encrypted smtp without startssl you should use a different port as mentioned above.

Yes…For STARTTLS, port mentioned is 587…I have set SMTP to port 587, ‘Encryption’ selected since STARTTLS is not shown

However, SMTP is for sending Email…For me, I cannot fetch the Email itself…incoming Emails…Error occurs here itself

No, it sais 465.

I’m not sure why you cant fetch mail then?

Beam is a native application.
You write about the Mail application giving an error, but Mail is just a viewer. You don’t configure mail servers in the Mail app, but the E-Mail preferences. Those are used to set up the mail_daemon which in your case seems to fail with your settings.

You can stop the mail_daemon in Terminal with

launch_roster stop x-vnd.Be-POST

Then start it with


Now you can watch the ouput of it in Terminal and may find clues why fetching mail fails.


I have set the E-mail preferences as per recommendations given on the website of disroot.org

IMAP as I wrote earlier, is totally unresponsive
POP3 throws out errors atleast, as written earlier

In the terminal, I keyed-in the commands that you mentioned
Nothing happens…black cursor keeps blinking

Weird. When I do that and fetch mail, it outputs pages and pages a second. I’d have bet you’ll at least get some sort of output, even with a misconfigured mail server.

i give up now

Beam works beautifully. Installed via Haikudepot…that means, extra…
Mail was already built-in…so , tried to useit till now…wasted many hours…maybe I have learnt some things…not really a waste of time