CD-ROM in Virtual Box

Hey, just coming back to the Haiku community after a couple of years away. Really amazed to see the progress and excited we’ll be seeing Alpha soon. I have the latest gcc2 build running in virtual box flawlessly from both WinXP and Ubuntu. I’m posting this from inside Haiku which I’ve been using for a while now and am impressed by the stability.

At the moment, I’m trying to get some files transferred in, specifically music and movies to start testing media playback. I created an .iso containing my files using a standard burning tool and mounted it as the CD-ROM drive, however I don’t see that drive in Haiku. How should it be showing up? Do I need to take any steps to mount it, etc?

Sorry if this is a noob question, or if its one thats been answered already. I googled and looked around and didn’t find an answer. Thanks in advance!

when you right click on the desktop there should be a mount menu, does this show the CD ?

If not then Drive-Setup lists all mounted and unmounted drives, you could then see if your virtual CD drive comes up there.

Originally, no, the CD was not showing up in mount menu. I tried your advice of going through Drive-Setup and saw the drive was listed correctly there. I then turned off my VM and tried a different .iso. This one showed up in the mount menu and worked no problem! When I rebooted again, switching back to the original .iso, it too showed up in the mount menu. Weird, but oh well, at least its working. Now I need to find out why some files play garbled and others just don’t play at all. Thanks for the help.