Can't get wifi to work on MacBook Air

I’ve installed R1b4 on a 2012 MacBook Air and I can’t get wifi to work.
I tried the script to no success. (No connectivity)
Any ideas?

1 Like

Use Ethernet or some of the supported USB wifi dongles. Haiku doesn’t support Broadcom, which Apple uses for wifi.

Check out Support for Realtek USB WiFi adapters now in nightlies - #6 by ilfelice

Would be nice if more hardware was supported. Broadcom isn’t exactly an uncommon wireless chipset provider. But for a temporary solution:

This worked for my 2012 MacBook Pro.

There is some more information about broadcom support in macs in this thread.

Anybody know of any recent progress or efforts towards this? I too would like to see good support for 2008-2018 Macs. With the recent switch to M1 arm64 chips, these ubiquitous Intel-based macs are plummeting in price and could be very nice Haiku machines.

I’m no driver developer, but I am experienced in embedded development and networking. If someone can point me in the right direction and assure me that this isn’t impossible, I’d be interested to contribute.

1 Like

I agree. I think hardware support efforts should be focused on older hardware that was popular. Pick a few popular vendors/models and focus on supporting them.

Hardware support is focused on whatever machines the developers writing drivers own and use. Currently we don’t have a lot of driver developper using Apple hardware.

And even with that focus, at least in my case, I decided to replace my 10 year old laptop with a new one, long before I could get everything on it 100% supported


The recommended wifi dongle worked for me as well.