Can't get wifi drivers from zip to install

I managed to get Haiku working on a partition on my MacBook Pro, but I’ve hit a wall with getting wifi to work. The MBP uses the Broadcom driver, and since mine doesn’t have an ethernet port, I need to follow the instructions at the bottom of this page to install them. I ran the script on macOS and downloaded the zip, then put it on a FAT32 drive so Haiku could read it.

From there I can’t figure out what to do. When I extract the .zip directly to /boot and try to run, the script doesn’t see anything and tries to download the drivers. I tried unzipping the file, renaming it something other than “system” and copy it to /boot (if I don’t rename it there’s no option to merge the folders when copying) and then run the script, but it gives me the following error:

I get the same error if I copy the file to /boot without compressing it as well. It seems like there’s something wrong with the .zip, but I tried restarting the process by redownloading the drivers and replacing the folder in /boot, but that didn’t fix it.

A tool to extract the firmware from broadcom drivers!/pkg/b43_fwcutter?bcguid=bc302-MQIGscreenshot586

Not sure what exactly to do with this. I can install the hpkg in HaikuDepot, but it still results in an error from bzip:


Is bzip2 installed?

This firmware files required only by some very old wifi chips. Are you sure you have one of this old cards? Chances you can spare the pointless fight wih the script (for example it won’t give you support for BCM4312 based cards which is very common). Could you post your wlan card type?

You may be using an older version of the script. Update your operating system.

The exact info from System Information is “AirPort Extreme (0x14E4, 0x152)”

The listed firmware version is Broadcom BCM43xx 1.0 ( AirPortDriverBrcmNIC-1615.1). It’s not old (unless 2015 is old, haha).

I’m on r1b2, the only way I could update it further (afaik) would be to switch to a nightly, is that correct?

Unfortunately, BCM43xx is not supported.

Correct but that won’t help it. Nightly images doesn’t have a driver for this card.

If that’s the case why does the script attempt to download it at all then? Not saying you’re wrong but that seems a little strange. Also, since Darwin supports it I’d imagine that FreeBSD has some support for it or it could be ported, since they share a number of elements.

I had a feeling that was the case, just wanted to make sure

Because some models are already supported, but it seems yours not.

Haiku uses the bwi driver from Freebsd, but yours would require the bwn one, which is not yet available on Haiku.

Try to swap your wlan card to a supported one.

The script does not check your hardware, it just downloads all the firmwares it knows about. It is useful only for old firmwares where the license didn’t allow redistribution. The firmware providers have since fixed the issue for newer firmwares, but never relicensed these old ones.