Can't get Scribus 1.5.2 to work


#41

Alright. I’ll try it tomorrow. Let’s get this thing to work. :wink:


#42

Miqlas,

I sent the new debug report to the Scribus issue tracker. It was checked out by jgalhi, one of the main developers. He said the problem is on the Qt 5.8 haiku port side. You can see his comment here: https://bugs.scribus.net/view.php?id=14843

Well if this is true, no Scribus 1.5.3 in Haiku for now. Could you forward this to the Qt maintainer?
or maybe I should wait until things become a more mature. If that is the case thank you so much.


#43

You can open bug reports at github.com/haikuports/haikuports (with links to the relevant info: this discussion and the scribus bug report).


#44

Hi folks,

After I read the news on the recent Qt 5.9 port success, I decided to take another try on compiling Scribus 1.5.3.
I erased my local haikuports tree and downloaded it again with the newest recipes of Scribus (updated by Miqlas) and Qt 5.9.
The building process went fine after I reinstalled all the dependencies. The app was built. It runs but shows the same bug I reported some weeks ago. It creates and opens documents but trying to use any tool to make or grab objects crashes the app without any dialog.
As it was said by one of Scribus’ developers in their forum above, the bug is in the Qt port code and should be fixed there.
So unfortunately no progress so far to bring this useful app to Haiku OS. :disappointed:


#45

Maybe you missed the comment above asking to open a bug report?


#46

I just did that (link here).
Thank you for pointing it out.


#47

Great attempt trying to compile Scribus 1.5.3…
While this is a development release, wouldn’t it be better to try compiling the Currently stable branch the 1.4.x series recommended for production!?

Would be great to have it work in Haiku…


#48

Scribus 1.4.6 is already available. And it seems to work, although I don’t have Ghostscript installed.


#49

Maybe you could bite the bullet and update the current recipe…


#50

Scribus 1.5.2 work fine. Newer versions are successfully compiled but do not work.


#51

3dEyes, please try with the new and development version Scribus 1.5.4 (27 April 2018), or try next week with the new Scribus 1.5.5 SVN.
Also there is the new stable version Scribus 1.4.7 (28 April 2018)

Thank you 3dEyes and other developers for your hard work!


#52

I tried to compile 1.5.3 and 1.5.4. Not worked for now.


#53

Have you tried to compile this stable Version?


#54

Scribus 1.4.7 for outdated Qt4.


#55

Not possible to update/compile Scribus 1.4.7 with Qt5?


#56

Scribus 1.5.2 is available in HaikuDepot now.


#57

And it works great! Thank you! :slight_smile: