Can't boot

I have had this issue before but can’t find the answer. I have just done a clean install of the Nightly Haiku image onto a system known to work very well with haiku. When I boot I get to a black screen with a flashing cursor in the top left corner, but nothing else. If I boot from the install CD and hit the space bar and selected the HD to boot from I can boot into it from there.

Also, I can’t remember when to use Intel or GUID to initialize the drive.

It sounds like you need to install bootman or another MBR to your disk. You can use the writembr or bootman commands to do that. Make sure to also run makebootable on the partition, just in case.

Ok, here is the current stuff that has been happening.

  1. I booted using the CD and used the CD tools to load the Boot Manager, then rebooted and tried to boot via the HD. I got the Haiku Boot Loader but it could not see the Haiku Partition.

So, I boot using the CD and my Haiku Partition was suddenly gone. So I reinstalled again. Now I am getting an error “Failed to Load OS…press any key to continue.” when trying to boot from HD, more then I got before but still not a successful install. When booting from CD, I can boot the HD from the Boot Loader on the CD.

I’m not sure how to run “makebootable” on the partition.

I never did really resolve this. I used an alternative method. I did not “Initialize” the drive this time. I just formatted the entire thing as BeFS. I know this isn’t the preferred method of installing Haiku, but I can always make it work this way. When I try the “correct” method if initializing the disk then creating a partition then formatting it I almost always have problems. I have, in the past, been able to work around the problem, but not this time. After almost 24 hours of trying, I gave up and did it the other way. Not really happy about it, but it does boot now.

It seems your BIOS is not happy with the intel partition map and/or the MBR code on it. Sometimes installing BootMan (the boot menu where you can select a partition) helps with that as it uses a different MBR. Or creating the partitions from a different OS with a different MBR code.

Having no partitions at all allows you to skip these problems and go straight into Haiku, which is fine if you only want one partition on the whole disk.

There is a bug in Drivesetup, it does not initialize discs correctly, i’ve had the exact same problems you described, you need to renitialize your disc with another tool like “Gparted” then create your partition normaly with Drivesetup.
I think there is a ticket for it on the trac, i’m not certain though, if not, would you please file a new one.


@khallebal - Thanks, at least I know I am not crazy.

@Pulkomandy - Ya, I am running on a laptop and just having Hakiu on it is just fine.