Can't boot newly installed system

Hello all,

I’m a long-time Linux user and a Haiku newbie. I have managed to install it on my SSD, but can not figure out how to boot to it. I tried creating the grub menuentry as given on the website, but update-grub throws several errors on it. I tried installing the Boot Manager from the Haiku USB, but it says all the disks are incompatible format.

Any ideas as to what I might try next?



It looks like your system is partitioned with GPT, and probably using EFI as well. In that case you need to install the EFI loader, and if you want to multi-boot with other systems, a good way to do that is using rEFInd.


Indeed, my system is GPT/EFI. The article you linked to should get me going. I’ll work on it a bit later.

Thanks for the pointer!

1 Like

Well, the instructions in that link did the trick, and now I can boot into Haiku! I’ve done a bit of poking around, took the tour, etc., and it is certainly a bit different. I am looking forward to getting comfortable with the system, and I’m sure I’ll have plenty of questions in future!