Can't access 'Network' panel

I have Haiku running in VMware using Iso but I’m unable to connect to the net as it’s impossible to write anything in the ‘network’ panel (Adapter = ‘device’) which I can’t alter. I’ve tried /boot/home/config/settings/network without any luck.

I’ve tried both cable and wireless/bridged, nat and host-only. VMware connects to net OK.

I’m using a laptop with Windows XP Home/Intel Core Duo CPU/PCMCIA-and Flash/Broadcom Netlink/Atheros Wireless/D-Link.

Any suggestions ?

what virtual NIC is vmware using ? The virtual PCNet32 NIC (vlance) ?

(Haiku is missing the vlance driver due to many people having problems with it; it can be found on bebits/haikuware, or you could just change NIC.)

Change network driver in vmware config to use Intel Pro 1000.

Use listdev in terminal to see what hardware Haiku detected in your emulator. Should show what network adapter it thinks you have. PCNet NIC is not supported.

Hi richienyhus/tonestone57

Checked listdev which said PCnet32 lance. As I couldn’t find out where to change the network driver in VMware config., [maybe as it was VMplayer], I changed over to Virtual Box. It didn’t connect at first either -but thanks to both - I finally configured it.

I’m sending this using Haiku/Iso/Atheros Wireless Adapter/100e/IntelPro 1000. :smiley: :smiley:

see: Can’t access ‘Network’ panel/solved.

see: Can’t access 'Network’panel/solved.

Good to hear.

For VMWare Player you must already have a config file as it does not allow configuration otherwise. Haiku provides a config file that should get networking going in Player.

Which can edited as needed. For instance, removing 2GB virtual drive (ide0:1 - Primary Slave) if you do not use it.