Cannot connect Haiku Repository

Hi. I am newbie in this community. I’m sorry for my unclear english.

I install Haiku on my laptop couple of weeks ago. I choose. Haiku r1beta4 (x86_64).

First time, I found HaikuDepot in deskbar. so I run it.

I don’t know How did HaikuDepot works. When I check repository, HaikuPorts is enable, but haiku doesn’t. It always returns ‘Failed: connection refused. Aborted: No error’.

What happen? ‘’ is gone? or temporary malfunction? or… I forgot something to connect?

1 Like

Ahoy @dsscrolls ,

First you should add evidence of you ask about – pasting something here AS
One picture ( or a Cut ‘n’ Paste text ) tells more than a word
as a saying says – and how it is right , …

So I assume – first you can check your repos added to Haiku system currently.

For me it is - in command line - the easiest :

~> pkgman list-repos
BeSly Software Solutions
priority: 2

            priority:  1

            priority:  1

            priority:  1

            priority:  1


These are above the 32bit version URLs - related to Haiku, Haikuports

If you are alienated to use command line,

you can enlist them in HaikuDepot as well :

( Sorry, still I could not find an appropriate picture editor here to cut out the just important part of the window - some of them too simple, some of them too complicated to use compared to a just as easy Irfanview or Paint related to this simple editing stuff as they do or I can use them. So I gave up on it and left the full window screenshot.)

1 )

Haiku Guide - Repositories

Once you reassured that you have the necassary repo configured - you can check its availability on your network.

  1. Does the domain name resolving work for the affected server of Haiku packages ?

~> ping -c1
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=52 time=33.426 ms ping statistics —
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/std-dev = 33.426/33.426/33.426/0.000 ms

1 Like

The most likely explanation is that your internet access isn’t working in Haiku, did you check that?


In WonderBrush:

  • With the Scissors tool > draw a rectangle around the area you want to preserve > hit Enter key (or click the green checkmark at the top)

  • Menu > Export as… > choose png or jpeg

  • Ta-da!

(When closing WonderBrush it will ask you to save the file you just already “saved”. You can simply discard it because it is asking you to save the file in it’s own native format)

You don’t need Wonderbrush for this.

In ShowImage:

  • use the selection tool to select a rectangle
  • drag and drop it to the desktop or any Tracker folder
  • a new “bitmap clip” file is created containing the selected part of the image

Open in ArtPaint and:

  • Use Selection tool to select the area.
  • Use menu Canvas | Crop… and hit ENTER.
  • ALT+S to save.
1 Like

And/Or… you could use the “UploadIt” Tracker Add-On (install from HaikuDepot)
right click on the “bitmap clip” choose the tracker Add-On “UploadIt”!

  • you get a link from (not important web-site 0x0.html/imgur?)

  • “alt-v” the link in your text to paste your picture!

P.S.: * right click and then drag and drop it to the desktop or any Tracker folder will let you choose what translator to use on your picture. .png or .jpeg and any other translators installed on your HAIKU system.

Thank you for replys.

My problem is not solved now.

first, my eth connection is fine.
secodn, ping to is good. no error.

but, haikudepot says that.

I don’t know why this error occur. do anyone know?

The Haiku repo is totally missing, weird?
Open a terminal and type the following, i hope this will help.

pkgman add$(getarch)/current

I don’t know what’s wrong, but did you try to remove all repos and re-add?

In Terminal, to easily copy&paste:

rm /boot/system/settings/package-repositories/Haiku
rm /boot/system/settings/package-repositories/HaikuPorts
pkgman add$(getarch)/current
pkgman add$(getarch)/current

What is your native language?
We have Haiku user all over the world…
Maybe it is easier for you then?

The “Terminal” program is in the Apps!
No install!

Ok, so I answer all the hints for cut out a part of a picture.
I reply to this first – as of course the screenshot opens in it by default.

Thanks for the hint - how I can solve my problem here - at ShowImage.

Just in all cases I could select the affected part of the picture - I just couldn’t solve to cut and save it. I wanted to click on “New …” under File but there were no such option , but Open only.
This way I could not Paste back to the program.
So this way ShowImage I classed as too simple.

Thanks for the hint to put the part on the Desktop or a folder. Nice.

So I felt myself :
I found a can , but I have no opener …

I went to ArtPaint as I thought it could be simple to cut something out and there should be File / New option there…

1 Like

Ok, so it was my next probation as I thought there will be New file.

Well there was , however it turned out quickly it is not a simple drawing program as at Cut there were layers and there were not simple new file but new Project where of course you are asked to add new canvas …
I do not like such stuff - this is I put a class as complicated when I just want a cut and paste only. Ok I understand - it is a drawing program , not a simpel picture editor.
Anyway I gave up on this here and wanted to check out another maybe simpler program to use cut and paste stuff. That’s when I set Canvas Generally bigger or smaller than the pic on the clipboard so I like if the program just give a blank window and fits to pasted in picture - in such cases.

When I read your Canvas | Crop hint …
I assume it does that for me. But to translate ArtPaint to earlier short story or parallell :
Someone give me a can … I see it first time … how should I know it is a food that needs an opener too. This way was ArtPaint for me -
That way I classed then : too complicated to cut and paste stuff.

1 Like

Well, I tried out Wonderbrush too.

It had the most special interface - I tried to use via mouse actions and menus … but now I know I should have used buttons.
I could select the wanted area, but under Edit - there were no Cut or Copy at all - So I left without saving the rectangle.
Now I know I can export the selected area against separate visible and save it.
Thanks for the hint - I will try out to experience it.

1 Like

As I said: Open the screenshot in ArtPaint. That implies saving it to a file first. The screenshot app does this very effectively. Then it’s a simple “Save” after your cropping.

1 Like

Well , in this case
I would say to open a Terminal and do the suggested repo removal and addition with pkgman as it was written by hundinger to you.

For example some folks could reinstall packages – to eliminate issues – with pkgman instead of HaikuDepot. So it can be a viable solution.

Sorry for my off topic replies. :j but I got the hints here.

Ok, I try it.


HaikuPorts is OK. but “Haiku” isn’t.

I don’t know what is going on.

No idea either…

Maybe start another Terminal and run tail -f /var/log/syslog.
Then do the above once more and see if anything shows up in the syslog.

Just in case: are you sure that Haiku have the right date and time configured? Not sure if could affect the repo configuration, but I remember issues trying to connect to some pages if the system date is wrong.


I check date and time in my computer. That is correct. It’s very mysterious…