Cannot boot from USB - locks up at splash screen


Ryzen 7 5700G
Radeon 6700 XT video card
Asus Prime X570 motherboard

Downloaded beta and burned it with rufus. Checksums match, so I know it’s not a bad rip. I’ve tried the nightlies and a different USB drive with the same result. It goes through the Haiku splash screen boot process where the icons lights up sequentially then hangs. I’ve tried the failsafe video driver, same story. Reset the BIOS to failsafe defaults, still hangs. I’ve taken a screenshot of where it hangs after setting the debug mode to on-screen.

Googling for this gives me a lot of old issues, mostly from 2012, but nothing I can see that helps. I really want to try out this OS, so if any help is available, I’ll take it.

Thanks in advance.


Please have a look here, gather infos, and open a ticket on Haiku bug tracker when you got them all.
You may get some help on the forum but the fix is probably not trivial, this post will end buried with time and the problem with it.


I can’t lodge a ticket, as the Trac website isn’t letting me create an account - it’s telling me it doesn’t match user policy, no matter what username I put in there.

If I remember correctly, it is a question of mail provider. Some of them are often use by spam bots, the filter learns from that and after a while it deducts that every account from this provider are suspects. You may have better luck with another mail address. Otherwise, perhaps @humdinger can have a look at it.

Tried my own domain’s address, which I know isn’t a spambot (nobody else uses it), and I’ve tried a gmail one I use. No luck with either. I’ll wait for help.

when did you try?

I don’t see any attempt in the log that failed and then wasn’t resolved with the captcha.

Edit: i see what you ment, username does not match the policy.
maybe the nick is too short? I don’t know the exact rules but this should be unrelated to your email domain. I registered with my own fine.

Yes, it seems it was a length issue. It’s all good now, and I’m in. Working on the ticket at the moment.

1 Like

FWIW, it might be worth trying to change your boot device order. I found something about it in an older discussion, and sure enough I can only get Haiku to boot from a USB stick on my B450 Pro if I put the USB drive as the first item in the boot priority list. If I try and use the boot menu instead to choose it, it doesn’t boot.

I assume that means there’s a bug in the UEFI loader or something, but don’t know enough about it.