Cannot assign disk for a swap

Are any specific requirements to disk to make it accessible as swap partition? I have formatted it as Intel partition map and as Be file system (whole disk), rebooted machine, but Haiku refuses to mount it. I have to mention that FreeBSD bootloader that boots Haiku as well sits on disk that I am trying to assign as swap

I tried the other day to use a different volume and it didn’t work either. I’m not sure it’s implemented at all, or maybe it used to work and got broken?

FWIW, it does work for me. Unchecking the “Automatic swap management” in the VirtualMemory prefs, I can choose any of the mounted volumes from the popup menu.

Reboot, and I find a “swap” file in the root of the chosen volume.


Of course, I have tried that. VirtualMemory prefs does not see that volume.

I think I found how to do that. It looks like at least 2 partitions has to be on volume. I created one small and another with maximal size. The latter became mountable and can be assigned as swap. After reboot Haiku remembers such configuration.

I want to thank the OP and everyone else who contributed to this thread. I had been using the whole disk and allowing automatic swap management on Haiku unlike Linux where I have a swap partion. After reading this thread I created a swap partion on Haiku, and the performance increase while using my web browser had been very noteable. Thank you!

So, you were able to use the whole separate disk with one single partition (not two, as in my case) and assign it as swap. Is it correct?

Created a new hard drive in VBox and assigned the swap to that, works fine here

A real hardware in my case

I used one HD, and created a second partition which I formated as BE file system. Once mounted I was able to assign it as my swap partition.