Can anyone use Parallells with the latest dev version?


#1

Ive been using Parallels for almost a year now, but some revisions back it wont boot anymore, its an 15 year old bug in the ati driver that were exposed. I am just wondering if its only my machine or do someone else have the same problem?

I decided to give qemu on mac a another shot and its suprisingly fast with HVF acceleration. But the soundhw (hda) crackles alot. Uses of Mac - what do you run Haiku with?

Here is my args for qemu: qemu-system-x86_64 -drive file=haiku.img,format=raw -m 8192 -soundhw hda -usb -accel hvf -cpu host -smp 2

Using smp 4 will result in a kdl - I havent reported this yet, though.

Update smp 4 works on my 2017 MBP (with Apples Hypervisor framwork) Reasonable speed.


#2

I use VMware Fusion to run Haiku on my MacBook Pro. Will try qemu with HVF to see if it performs any better.


#3

I think you’ll need to use qemu 4.x version to get hvf.


#4

I installed qemu with brew

qemu-system-x86_64 --version
QEMU emulator version 4.0.0

Does it have hvf?


#5

Yes I think so.


#6

I tried running hrev53365 x86_64 in qemu and found it several times slower than VMware Fusion.

qemu-system-x86_64 -drive file=haiku-nightly.image,format=raw -m 1G -soundhw hda -usb -accel hvf -cpu host -smp 2

My CPU is:
sysctl -n machdep.cpu.brand_string
Intel® Core™ i7-3635QM CPU @ 2.40GHz

However Haiku detects it as just “Intel” in AboutSystem despite -cpu host option.


#7

Strange. I noticed that Qemu and VirtualBox is much faster on my older computer:

I have the following two MBP.
2013: Intel® Core™ i7-4850HQ CPU @ 2.30GHz
2017: Intel® Core™ i7-7920HQ CPU @ 3.10GHz

Where the 2013 is a lot faster in qemu and VirtualBox.

I can no longer run Haiku in Parallels, its unbootable since a month back or so. I dont think I want to spend another $100 on a virtualization software. So now I am experimenting with qemu (haxm accel=hax) seemes like its way faster than hvf but Haiku KDL though to a bug in in the scheduler if you use more than one thread of core.


#8

Looking through the report I’m not entirely sure it is a Haiku bug. Considering it has never been reported previously, it seems suspect to be a QEMU bug that only occurs under HAXM or something like that. But of course it could be some legitimate difference in behavior we are not handling correctly.


#9

With HAXM acceleration qemu exits right away here:
qemu-system-x86_64 -drive file=haiku-nightly.image,format=raw -m 1G -soundhw hda -usb haxm accel=hax -smp 2
qemu-system-x86_64: haxm: drive with bus=0, unit=0 (index=0) exists


#10

Remove -smp 2 and it works. Or try using -disable-acpi as Haiku uses ACPI to detect smp/cpu features. (Maybe all OS’s does, I am no expert here, just had luck reading the serial output from Haiku).

If you need more ram for HAXM you can: (HAXM installation folder)
./silent_install.sh -u
./silent_install.sh -m 4096

Otherwise you’re stuck with ~1GB.


#11

Removing -smp 2 doesn’t make any difference, unfortunately.


#12

Try this one:
qemu-system-x86_64 -drive file=haiku-nightly.image,format=raw -m 1G -soundhw hda -accel hax


#13

This gives:

Failed to open the hax module
No accelerator found.
qemu-system-x86_64: failed to initialize HAX: Operation not supported by device


#14

Have you installed the HAXM-driver? https://github.com/intel/haxm/releases


#15

Nope :slight_smile: Did that and it works now.

HAX is working and emulator runs in fast virt mode.

However, that didn’t improve a thing. For instance, opening every preferences at once (from Deskbar) takes more than 30 seconds. So, I’m not sure what’s going on here, maybe my CPU doesn’t really support that.


#16

My 2017 MBP is much slower than my 2013. Paralells and Veertu are much faster than Qemu. But I got reasonable speed on my old laptop.


#17

Could you compare all this VMs to VMware on both MBPs. It would be interesting to see a chart of how different VMs perform. As for me VMware is the fastest on this MacBook I have here.


#18

I runned some CPU benchmarks today in Qemu and switched acceleration between runs (tcg, hax and hvf). HAX is almost twice as fast compared to tcg (virtual software CPUs) and HVF (AppleHyperVisor.Framework).

Veertu is no longer supported by the company and they removed their source from github. There is no sound and network is unstable.

Parallels is very fast (running 2-4 cores, using 8Gb memory). Everything works (if Haiku boots, which is doesnt do anymore though to a bug in the ata driver).

VirtualBox boots really fast (fastest of all), but moving windows etc is really slow.

VMWare (I have to purchase WMWare, my eval period ended).