Calligra will not install on 64-bit beta 2

Hello everyone!
I have been following the project for a while, and installed it on some of my computers (I’m into retrocomputing so I have a few of old machines) for testing. Today I’ve just installed the newly released Beta 2 on my trusty old socket 754-based Athlon64 3000+ and, to my surprise, could not install Calligra from Haiku Depot. I’ve installed it on my very old Pentium M laptop and another not as old Core2 Duo one in a nightly x86 Haiku build a few weeks ago, and it worked fine. Is this a bug I should create a ticket to?
Here is the error message:

Encountered problems:
problem 1: nothing provides lib:libcrypto>=1.0.0 needed by khtml-5.65.0-4
  solution 1:
    - do not install "providing calligra"
Please select a solution, skip the problem for now or quit.
select [1/s/q]: 

I have checked and I do have openssl installed.



Similar issue here, also with the x86_64 build of r1/beta2. I’ve tried installing Subversion and MAME from HaikuPorts and have gotten a similar message. Was this an oversight of sorts, or is libcrypto referred to in another package, by any chance?

Fixed. khtml package rebuilded with openssl 1.1 - try again please.


It is installing now, thanks!