Building on Linux (again)

Hello, I’ve been unable to build Haiku from source on Linux for about a year now and would like to start doing so again. With a fresh pull, my latest attempt on the master branch looks like this – this is 32 bit Gentoo Linux with gcc-10.2.0. Any ideas?
That is a clean build; only download/ and UserBuildConfig in the current directory. As the build command shows, it’s an out-of-tree build.
Do people generally build Haiku on Haiku nowadays? I wonder if bootstrapping via Linux is abandoned.
I use it on a Wyse thin client with a 2 GiB flash storage because I can boot Linux with an NFS root and keep the flash free for Haiku.

No, most of the nightlies are still built on Linux. Newer GCCs often do not build GCC2 well since the source is so old, you may have much more success with an x86_64 build only.

Developing Haiku on Haiku is typically much faster than using Linux though, indeed.

I’ve tried gcc 10.2.0, 9.3.0, 8.3.1 and 6.5.0 which is as far back as Gentoo provides, with the same result in each case.
It does seem to me that the bug arises from something in the build system (i.e., expecting a directory to be empty when it’s not) as opposed to a source compilation fault.
As the hardware is 32 bit, I can’t agree with your statement that you may have much more success with an x86_64 build only.

gcc2 built fine in the provided logs. The problem is with building the new binutils for gcc9, apparently.

Which flavour of Linux does the Haiku build system use?

Haiku is not Linux, so it has his own way :smile::wink:

They use Fedora or Ubuntu according to

The answer is that you must run make distclean in buildtools/binutils.