Broadcom WiFi adapter support in the R1/Beta


#1

Is there still a way to get drivers for Broadcom WiFi adapters installed in the beta? The method described at the bottom of this page no longer works since the boot directory is now read-only. Would it be possible to create a package for users to install after the first boot?


#2

All available drivers are already included in the beta. Unless you’re speaking of firmware?


#3

That is a deprecated page. But what’s described still works. The script has been adjusted to package management. You’ll still have to unzip to /boot.


#4

Yes, I’m talking about firmware.


#5

Oh, well that’s great to hear! The one that worked for me was the script intended for Haiku installs. Would it be a good idea to have a way of telling users (where applicable) to run install-wifi-firmwares.sh after installation? Maybe it can be an optional step or checkbox in the Installer?

EDIT: Even after running the script, the WiFi adapter (BCM4313) still doesn’t work. It is detected in Devices but there is no information provided in any of the tabs. Is there anything else that I need to do?


#6

Sure. Anything logically consistent can be coded. :slight_smile:
You could file an enhancement ticket for it.

To make sure that the firmware was actually installed, does the folder /boot/system/data/firmware/broadcom43xx exist on your system?


#7

IIRC, this adapter is not supported by any driver we have in the tree (bcm43xx supports only up to 4311, I think.)


#8

Hello everyone. I have the same wifi adapter. There is no chance of being able to make it work?


#9

No, unless someone writes/ports a driver.


#10

Is this at all helpful ?

http://landonf.org/code/freebsd/Broadcom_WiFi_Improvements.20180122.html

I am trying to get my head around C programming at present and would love to help out if I can.

After reading all the discussion about Broadcom wifi drivers in Haiku it sounds like the problem is in some way linked to the kernel and not just the driver itself.

BB