Broadcom 43xx driver isn't seen by the script

It’s exactly as the title says. My laptop has no internet connection besides it on Haiku, so I booted into Linux, grabbed the files I needed, and extracted the archive to /boot. Then I ran, and it completely ignored the already there b43xx driver and tried to download one from the Internet, which it of course failed to do. So now I’m stuck. Any help would be appreciated, thanks if you drop a reply.


it seem same case here? Broadcom BCM4312 - will it be supported, and if so, when?

No, not that I can tell; mine is a 4318, which as far as I can tell is supported; the problem is that the script to install the driver doesn’t see the already provided driver and tries to install it off the internet, but as I don’t have a way to connect it to the internet, it won’t ever actually download a replacement, and it won’t ever use the driver I already extracted to the right folder.

No, you misunderstood: for your kind of cards 2 seaparate things required:

  • the driver (provided by Haiku)
  • the firmwares (not distributable with Haiku)

The script tries to download the firmware, not the driver itself.

The script obviously won’t work without internet conenction, so you can either:

  • use a wired connection temporarily
  • download the required files in other OS

If you pick the second way, you should read the user guide:

I already did that, let me walk you through what I did:
-went to that page
-saved the script on the page as .sh, ran under Linux, got the files
-copied the resulting .zip and folder to a usb hard drive and booted Haiku, and copied those to my home folder
-extracted the .zip file to /root
and it still tried downloading the files I provided off the internet.

You don’t try to run the same script in Haiku, right? Haiku install provides a different one, which takes the predownloaded/extracted files, and installs it.

After extracting the files, I open the terminal and type in “” as the page tells me to do.

Works just fine here, but here you go, rename this to wifi_firmwares-1-any.hpkg and copy it to your Haiku machine with an usb key or something.


It’s not giving me the option to install it.IMG_20201120_005208

Try to drop it int /boot/system/packages manually and then reboot.

1 Like

That worked, thank you very much. Gonna set up now.

Then please create a bugreport at with the actual script outputs (the photos are just not containing enough info) so one can investigate what went wrong on your side

Alright, done, and through WebPositive at that.

1 Like