BootLoader Crashes with USB Boot On Lenovo S12

Well I’m probably very New to Haiku, So I was wondering if This is a mistake on my end or is it The hardware. But bottom line: I’ve used rufus and Released Beta 2 to Make a bootable flash drive. Upon boot up I’m greeted with Boot loader Death Land?
15964488201091777048944923403808
The Laptop is a Lenovo S12 with 1gb Of DDR2 RAM and an intel Atom n270 @1.6GHZ

Thanks!

There is more info needed to help you here!
As in most cases these steps will be needed:

From what medium did you try to install Haiku from? CD, DVD, USB?
How did you prepare the computer to run Haiku on? Did you format it with the installer from the Boot medium?
32bit or 64bit?
Just give some more information about your steps about trying to install Haiku…

I used echter to burn the iso onto a USB flash drive. Immediately after trying to boot to the USB. This crash happens before Haiku logo.

I’m using Haiku since Alpha/1 but I never saw that error!

Anyboot ISO? Do you have other pendrive to make sure it isn’t corrupted? I’ve always used dd.

1 Like

Yea i’ve used the Anyboot ISO. i tried the same Pendrive on another Computer and it seemed to work just fine. The Computer it worked on was a 2nd Gen Core i5+ 16GB Of RAM+ GTX 650 + Some asus board so i don’t believe the pendrive is corrupted. So i believe something with the Laptop and Haiku aren’t working something with Memory possibly?
It’s worth mentioning the Laptop uses integrated intel Graphics I heared that doesnt always work with Haiku?

Heres the picture from the 2nd PC:
20200803_133843

Atom n270 is a 32bit processor, isn’t it? Did you take 32 bit version?

1 Like

Yes I have. Both the public and nightly.
15965375489924932835360156891324
15965375886501598209110715256833

Then I guess next move is to open a ticket on Haiku bug tracker.
Give as much details as you can. How you booted (USB ), how you made it (etcher), versions that you tried including hrev number (32bit hybrid beta2 and 32bit hybrid nightly hrev…), list of your hardware (gathered with another OS), screnshot of the problem), and a maybe a link to this thread.
Once done, post here the link to your ticket so nobody ask you to do it again and more important if someone comes up on forum with the same problem they can follow it.

1 Like

i see. i’ll do that.

https://dev.haiku-os.org/ticket/16467 There.

Those multi-OS loaders like Rufus, MultiBootUSB or Ventoy will not work with Haiku for now. They all use various tricks to inject kernel modules or initrd files or some other things into the OS they load to make it think the ISO file is an actual drive. Since Haiku isn’t Windows nor Linux they have no known way to do this, and the Haiku loader will not find anything to boot from. Which is a shame since BeOS used to do the exact same trick as those do with the IMAGE.BE trick of booting from an image file in a FAT partition.

3 Likes

This; if someone’s on ReactOS or Windows, Win32DiskImager works the best https://sourceforge.net/projects/win32diskimager/

I’ve used a Haiku guide and used etcher aswell https://www.haiku-os.org/guides/installing/making_haiku_usb_stick/ this one.

Ill give it a try now.

Hmm, did you try all USB ports?

1 Like

Yep. Each one same result.

i’ve tried with win32disk imager. same result. as i said. it worked on a different PC. but it does not work with this one. i’ve already had windows XP and ReactOS installed on this Laptop. so i don’t think the RAM is bad or something like that.

Well, that’s exciting. I imagine something must have blown up big time for it to be spitting out the current register values and some sort of debug info regarding stack frames.

I want to say I booted an older version of Haiku from a USB stick on my HP T5740 (has an Intel Atom N280) once and it seemed to start up fine, though it wasn’t this latest version. So I’m sure the processor is not an issue (you know unless your model actually has the Via Nano processor instead) and if you were doing fine running some other OS the ram is probably okay. With just a single stick of ram and not very much (relative to modern configs) I would think any serious fault there would out itself quickly.

https://en.wikipedia.org/wiki/Lenovo_IdeaPad_S12
https://en.wikipedia.org/wiki/Nvidia_Ion
https://www.newegg.com/p/N82E16834146577

Looking at this, I’d speculate the graphics could be part of the problem. I assume you do in fact have the Intel Atom N270 version, so:

Looking at the Newegg listing it appears that this machine uses the Intel 945GSE chipset which brings the Intel GMA 950, but according to the wiki page NVidia Ion is also included somehow. So that means there is also an NVidia GeForce 9400M G kicking around somewhere. No idea what support for those is like, maybe switching between them is part of the problem?

I’d recommend giving some of the bootloaders options a try if you can make it that far into the process:

https://www.haiku-os.org/docs/userguide/en/bootloader.html

Of particular note is the ‘Use fail-safe graphics driver’ option; if you can successfully boot with that option then the issue is likely related to graphics. There are also some other options for getting ahold of syslog data.

P.S.

Possibly related to whatever caused the problem in this ticket:
https://dev.haiku-os.org/ticket/10351

One of the comments on that ticket reports that a similar problem was found with the Lenovo IdeaPad S10e which has very similar specs to the Lenovo IdeaPad S12 (different screen size?).

https://www.cnet.com/products/lenovo-ideapad-s10e/specs/
https://www.cnet.com/products/lenovo-ideapad-s12/specs/#p=lenovo-ideapad-s12-intel-atom-n270-1-6ghz-1gb-ram-160gb-hdd-xp-home-black/

The submitter of the ticket also noted that his Acer Aspire One A110L did not work either… Notably that system also uses the same cpu+chipset as the Lenovo models…

https://www.cnet.com/products/acer-aspire-one-a110l-8-9-atom-n270-linux-linpus-lite-512-mb-ram-8-gb-ssd-series/

P.P.S.

https://sites.google.com/view/hardware-list-for-haiku/notebooks-thinbooks-cloudbooks-etc
Acer Aspire One AOA150

Intriguingly the person who posted a compatbility report for this system indicates that it shares the same cpu and chipset as above and yet reports that it mostly works fine… They indicate the version used as hrev54460, so maybe it worth trying that image?