Booting Haiku in HP/Compaq nc8230 laptop (from HDD)


Old BeOS-lover getting “back to the game” with the recent Haiku R1A41. I’m currently using a recent nightly on my “test computer”, but wanted to try “resurrecting” an old laptop for light use - instantly thought of Haiku to fill that spot.

However, everything is not well in my Haiku-land. I have made a bootable USB drive from the anyboot R1A4 image from this website. And successfully used it multiple times on a couple of computers.

On this laptop, it boots 100%. It even recognizes the laptop’s somewhat weird display adapter and screen -combo perfectly and displays it in a native res (1680x1050).

However, if I then proceed to install Haiku to the laptop’s HDD, things get strange. It installs (apparently) fine, no errors, everything goes well. But after a reboot it just doesn’t boot.

I’ve tried:

  • Haiku’s own Boot Manager

  • GRUB

  • GRUB2

  • Using the laptop’s own 40Gb IDE HDD

  • trying with a IDE-to-SD adapter with 8Gb Transcend card (this would be the ideal and what I’m working towards) and a Kingston 16GB, 8Gb and 2Gb card.

  • Using the aforementioned cards in the laptop’s integrated SD-reader

  • using said cards in a couple of USB-SD readers.

Nothing works. (Xubuntu boots perfectly from ANY of the choices), after the “Loading System.” text quickly flashes in the top left corner, the computer reboots instantly and starts over. There’s no loading screen, nothing. Even the text doesn’t always display, it just plainly reboots instantly after choosing Haiku from any of the boot managers.

I would accept the fact that the laptop is totally incompatible with Haiku, BUT it boots and works perfectly from the anyboot USB-stick.

I’m at a loss of what to try next. I can’t think of anything I haven’t tried and it just doesn’t work with ANYTHING but the USB drive.

EDIT: Here’s a link to the specs of the device:
(Mine’s the 1.86GHz Pentium M -version)

EDIT2: Also it says “Loading Haiku”, not System, in that text, sorry :slight_smile:

safe mode options ?

I have occasionally had a similar issue, and resolved it by manually adding the boot sector (second item on tools menu in installer).

That’s what I tried to access, but unfortunately the reboot occurs regardless (or before, I don’t know). In the Haiku Boot Menu (or grub, or whatever), if I press enter to start loading the OS (it doesn’t matter if I hold down shift or not), the text “Loading Haiku” appears in the top left corner for, I don’t know, 0.2 seconds? perhaps 0.5, not more. Then the computer’s boot process starts like I had just turned it on (from power-off state, in other words, the computer cold-boots).

For the other reply: I tried that also (adding the boot sector manually), unfortunately it doesn’t do anything.

It clearly recognizes Haiku (“Loading Haiku”), and there’s nothing inherently wrong with the boot device (since it works with all other OS flavors AND it boots correctly to the Haiku Boot Menu, if installed).

Is there something different in the anyboot boot process than a “regular”, “installed” Haiku version?