Booting Haiku and hangs - Dell Inspiron 1000

Hardware: Dell Inspiron 1000; 512 MB RAM;
BIOS vers A06

I just downloaded and tried to boot from a Haiku CD…and it hangs during the boot process.

As far as the Welcome Screen icons, it lights up: atom; disk/magnifier; and plug-in card.
I’ve never seen it go past this.

I tried holding SHIFT to go into the boot loader. Booting in safe mode makes no difference.
I also tried booting with user add-ons diabled. No difference.

When I send debug messages to the screen, every time the log stops at these lines:

usb uhci: no devices found
usb ohci -1: iospace offset: 0xe4000000
add_memory_type_range (132, 0xe4000000, 0x1000, 0)
usb ohci -1: smm is in control of the host controller

I’m not sure what to try next.

Hello! I’m not sure, but appears to be a problem related to the USB: try unplugging any USB devices.

Another thing to test is playing with the USB related configuration from the BIOS; or directly, disabling it.

You are trying Alpha 4.1, or a Nigtly Build?

PD: Sorry for my bad english!

Hi There,

I am using release: Version: R1/Alpha 4.1

There aren’t any USB devices connected.

The BIOS has limited options about USB. The only one is “USB Legacy Support” (enable/disable). I’ve tried both.

Maybe since the Haiku boot icon it stops at/before is the one about HDD this is about the HDD?
The HDD is a 80GB: Toshiba MK8032GAX-(PM)


As Kim suggest, try with a recent Nightly Build (x86_gcc2_hybrid) (Alpha 4.1 is already old: is from 2 years ago):

ok, I tried the nightly build (downloaded it and burned a DVD to boot from).

It seems to do more during the boot process, but ultimately hangs at the same point.

The boot debug output ends with this:

publish device: node 0x833268d8, path power/embedded controller/0, module drivers/power/acpi_embedded_controller/device_v1
module: Search for busses/usb/xhci fialed.
usb uhci: no devices found
usb ohci -1: iospace offset: 0xe4000000
add_memory_range(219, 0xe4000000, 0x1000, 0)
usb ohci -1: smm is in control of the host controller


The output stays the same whether I boot normally, or in Safe Mode and disabled User Add-ons.

It also doesn’t seem to matter if, in the BIOS, I have USB Legacy Support enabled or disabled.

Also as before, the first three boot icons are lit up (atom, etc…) but never the fourth icon. I waited a while too, in case it was “doing something”, but it never changes after that point.

I tried to get into debug mode, but I am not exactly sure how to do it on this keyboard.
The Sysrq key is in blue letters, sharing with the Prnt Scrn.
The blue color means I need to press the Fn (function key) to access it.

So, I’ve tried a bunch of combinations and orders between ALT, FN, SYSRQ and D… but so far it hasn’t dropped to the debug prompt.

Is there an option on the bootloader menu I can do to force it into debug right away and avoid this “keyboard finger dance”?

If still can’t boot Haiku; you could fill a ticket in the Bug Tracker, with this info.
Maybe some developer could help you.