Booting from NVMe - a couple of questions about expectations

So I just recently got my Haiku install to boot from the NVMe, and there are a couple of ‘odd’ things that I’d like to run past y’all.

  1. The first thing that displays when booting Haiku is a 'Welcome to the Haiku Boot Loader" screen, where I have to select a boot volume. The default shows (Current: None). Is it normal to see this every time I boot the NVMe?

  2. I have a USB WiFi card that Haiku supports, but it does not automatically connect to my local WiFi. I have to initiate the connect. I remembers the password and connects without issue. I can’t find a preference to ‘automatically connect on boot’. Does this not exist yet?



1 Like
  1. This is a bug, please file a ticket

  2. This is also a bug, a longer known one too, nobody fixed it yet unfortunately (there is also a ticket already, don’t have it at hand)

Did you set the partition type to Haiku BFS as indicated in your grub menu thread? It had a type of Microsoft basic data.


Thanks - I had overlooked that step. I was able to use gdisk on linux and was successful.

Another interesting thing if I may.

Now that I have the NVMe booting properly (thanks to all) I’ve moved icons around, added some, and am using it for builds (and eventually development). I cloned the HEAD of the tools and haiku repositories, ran a build, and burned the resulting ISO to a USB stick. I then restarted the computer with the USB stick installed, and told the BIOS to boot from USB (something I’ve done hundreds of times in the past couple of weeks).

Here’s the interesting part - at some point during the USB boot process, Haiku decided to switch to the NVMe as the boot device. Once booted, I find that the desktop displays all the icons that I added/moved around, and the DriveSetup program shows the NVMe as mounted, and the USB as not mounted. It looks, to me anyway, as if I had booted the NVMe from the start.

As a test, I temporarily changed the NVMe partition type ID to ‘Microsoft Basic Data’, and booted the USB again, and this time everything went as expected, and I was presented with the installer screen, so I know that the USB stick can in fact boot.

It appears to the untrained eye (that would be me …) that the boot routine that detects and returns partition information about where the system is booting from prefers the NVMe when it is available, and only when the NVMe is not available does it return information about the USB stick.

Is this expected? Has anyone seen this behavior before?


1 Like

Not really, but it’s possible that the bootloader didn’t manage to find which drive it was booted from.

On EFI systems, it seems the simplest way to handle this is to go through Haiku’s early boot menu (the one you got before setting your partition ID), which you can access by spamming the spacebar during boot (before the bootlogo shows up). You can do this with the bootloader loading from NVMe.

From there you can use “select boot volume” and then boot from your USB drive if you want. In most cases (if you’re not working on modifying the bootloader) this will be enough to test your changes to Haiku.

Whether I initiate boot from the NVMe or the USB stick, at the point where the early boot menu is displayed, the only choice is the NVMe. There are no USB volumes displayed at all to pick from. Even if I select ‘rescan’ it doesn’t find the USB device. The USB stick has R1/beta4 on it.