"boot volume not valid" after install

hello i can boot from usb and install haiku fine but when i reboot and remove my usb haiku bootloader says “boot volume not valid” (this happens when i format the disk to bfs without creatiting partitions but if i create intel partition map and install it says no sys loader) also wifi doesnt work

create intel partition map
create partition (active / bootable flag set)
format partition
install Haiku
install boot menu


format disk
install Haiku
NO! boot menu

i tried both and both didnt work
eventually i switched to linux again
edit:i might try it again since i cant install drivers

1 Like

!! delete old partition map/table !! operation required

I’m just wondering if you checked to make sure the partition had an active / bootable flag set, otherwise no joy on trying to boot from it.

1 Like

ok so my guess is haiku doesnt support big partitions like 1tb which i was trying to install haiku to(i made a 125gb partition and installed haiku on it it worked fine but didnt detect wifi)

listdev in Terminal