Boot screen stuck at the rocket

So I have my PC where I had Haiku
At first, it was difficult to install it because the USB drive didn’t boot, and I had to copy the install partition to the HDD and then boot it from there and bla bla (posted about that when it happened)
Then, I bought an Nvidia GPU, and till now I get that error :stuck_out_tongue:
That was a long time ago, and as nothing worked, I gave up.
Now I wanted to try again. tried to use only the iGPU, failsafe mode, nothing yet.
So any advice would be appreciated
PD: As I have no access to the system, I don’t know how I can get a syslog :stuck_out_tongue:

Sell the new PC and buy an old Thinkpad, like a T61. You will save yourself a lot of grief.

It is possible to display syslog on screen during booting:

  1. Repeately press spacebar, Haiku Boot Loader Menu should appear.
  2. Select Select debug options > Enable on screen debug output.
  3. Go back with Esc key and select Continue booting.
  4. Press P to disable paging.
  5. Wait until system will freeze.
  6. Take screen photo and post here.

Haiku should support any x86 BIOS/UEFI hardware if have required amount of RAM. It’s better to identify and fix problem.


Okay, so I did that trying 3 configs (Take in mind I have 3 screens, 2 for the Nvidia card and one for the iGPU)

  1. My usual config(Nvidia main, multi GPU)
  2. Nvidia main, changed resolution to 1024x768
  3. IGPU main, disabled multi GPU, 800x600image
    Hope this can help ;p

You can buy something like a T420 or X220 and you’d still be fine. No need to go for something this old.

And, even newer hardware should work. Haiku is not specifically targetting old computers, let’s fix the bugs instead!

@jose64141, are you booting using legacy BIOS or EFI? Can you try both? Your problem is in the VESA driver and its implementation is quite different between the two (using VESA in BIOS mode, and using EFI calls in EFI mode).

Sure, but the T61 is cheaper and works fine. I have several running W10 and MS Office. They are very capable machines.

For some reason the X230 is very good value on Ebay, but personally I prefer a larger screen. Perhaps that’s why is good value.

I do agree about fixing the bug, if practicable, but if somebody is busy, getting proven hardware will save some time.

Oh, haven’t thought of that. I tried; using the Nvidia screen had me with a black screen after the boot loader, and when I tried with the iGPU it worked!
So now we have to se what’s going on with EFI and Nvidia stuff ;p
Is there anything you want me to check within Haiku?
And also, congrats for fixing the usb stack ;D
Now I can use my mouse without random moves and lags XD

I have a gen7 intel iris pro5500 with the same symptoms (stops on rocket) and have to disable the intel_extreme driver for Haiku to boot. From the boot menu (hold shift or continuously press space), disable the add-ons/drivers/video/intel_extreme package and you should be able to boot into a vesa desktop. Good luck.

If the above suggestion works, then follow the guides to permanently blacklist a package.

1 Like

Yeah, I though of that, but I didn’t know the route so didn’t try XD
Although using the UHD in legacy mode worked fine
So there must be a trouble between the EFI stuff and Nvidia (why OSS and Nvidia can get along :frowning:)

1 Like

Try enabling “fail safe video mode” and then pick a specific video mode in the bootloader. You can see onscreen debug output, so clearly the OS initialized the framebuffer properly, but perhaps trying to run VESA or the like failed (that seems to be the last message in the log.)

I did try both
When I tried fail safe video mode, the story was the same
And when I selected resolution, the thing stoped, as you can see in the screenshots

Btw, given the fact that this is more of an issue than a simple problem, I should open a ticket if it shouldn’t I?

Yeah :slight_smile: Include as much information as you can, including the haiku hrev, system information, boot methods (EFI from USB, etc) and the log screenshots.

You can also use the BeSlySystemAnalysisTool to catch system Information. You can Export and add it into the bug tracker.


Just look into the dump before you post it anywhere as it can easily contain plenty private information.

Okey, so I booted Haiku from my HD, using CSM and I got this
Any ideas or suggestions?
Update: Tried the same on the live USB (which worked before), and got the same
(Now I booted with the multiGPU support)

This is a problem with HDA (audio adapter) driver. Report it to Write Haiku version (hrev…), set component to Drivers -> Audio -> HDA and attach crash photo.

You can avoid crash by using safe mode in boot loader.

Do you know how I can dump the syslog from

You can use syslog | tail.