Boot options issues on UEFI

Today I tried to install Haiku on a spare drive of my old Intel i7 Haswell box which proved to be more difficult than I thought. The box used to run Haiku until Beta1 without issues, but then the drive and graphics card failed.
Now I have an AMD Radeon 5500 installed and I wanted to start a clean install via USB. But the card seems to be not supported by Haiku, at least booting ends up in white KDL screen. So I wanted to use boot options to force VESA mode, but regardless what I do, the options are not displayed. Hitting fanatically either Shift, Space or both does nothing.
I needed to boot with active CSM from a freshly created CD to be able to change boot options (which also only sometimes works, not always).
Since the installation resulted in a complete sluggish system (up to 5 Minutes before reaching the desktop), I wanted to try more fail-safe options. But always using CD to boot is a tedious thing.
So is there a possibility to configure the system to show the boot options with every boot?

at least booting ends up in white KDL

Please open a ticket with a picture on

I don’t think there is a way to force the boot menu to show up every time.

Shift doesn’t work in UEFI mode.

Sadly, on my system nothing works to get the options…

I just spam the SPACE bar. Like 1000 times very fast. Here on my machine this works.

Hi, you no longer have to hit spacebar a lot, maybe two three times. You should make sure you update the .efi file on efi partition though if you have a very old one. I really want to get away from the notion that you need to spam space. We don’t want people to wear out their spacebars. They are kind of important for typing.

1 Like

I still spam my spacebar. Gotta make sure I get into haiku_loader :smiley:


I just hold the spacebar down until the menu appears. Works just as well.


Haha. You guys are funny. @MrEntropy Sounds like the best approach. Will try! Thank you.

1 Like

I do exactly the same :slight_smile:


Sorry, EFI boot is considerably broken, at least on my systems. For my Desktop, I am using an older bootx64.efi (571259 bytes, I think it is Beta3). If I use the one coming from a later version, like hrev55732, I get a black screen and no boot at all.
Booting from a USB drive with the old EFI will allow me to use space bar, booting with the same EFI from an internal HDD will not.
But the boot will take up to 12 minutes until Desktop is available, and all icons are displayed. After that, there is no lag or sluggish behaviour, the system is usable.
On my Thinkpad Laptop (x220) I can boot with the latest EFI loader, but the graphics (Haiku logo, icons,…) are completely distorted until I reach the Desktop.

1 Like

Tried! Works. Just quickly after booting hold space bar down until Haiku bootloader shows up. Thanks. Best Haiku survival tip ever :smiley:


When loading Haiku (hrev55763-x86_64) from Grub (uefi) menu, Haiku does not automatically find the kernel, you have to choose from the menu. NVME Drive, dual boot with Linux. Efi boot file copied from Haiku install usb. What can be wrong? Or this is “normal” for now?

Did you updated (manually) the efi file lately? If not: try it.

The same with new efi file, after choosing “Haiku” from grub menu I get “Select boot volume (Current: None)” in Haiku boot menu.
I get updated efi file from installed system folder “/system/data/platform_loaders/that_file_name.efi” and renamed it to “BOOTX64.EFI”, and puted in “/EFI/HAIKU/”

Entry in grub menu:

menuentry “Haiku” {
insmod part_msdos
insmod chain
search --fs-uuid --set=root 91B8-B57A
chainloader ($root)/EFI/HAIKU/BOOTX64.EFI

Update on href55771 update (x86_64, the same hardware).
Now when grub loads Haiku entry: black screen and nothing going forward, to boot I need to hold space, and choose from menu Haiku kernel.