Boot haiku natively

drive setup,YEAH…


—>I’m working as fast as the germans will let me.

translation takes a minute…

appears drive if done that way(used blank and formatted within HAIKU) installed with makebootable (and/or) dump of ZETA bootloader (dd onto /dev/disk/0/ata/slave/raw) gives the following message.

NOTE: this attempts to allow installation of bootloader on main system drive.

“the partition hooked up ON non removable disk lies too near at the beginning the non removable disk that boot managers cannot be installed”

(partition too close to beginning of drive)

here’s the rest of the messages you missed:


SCBI BIOS not read.Please examine your drive to ensure they are setup correctly.
this error can also occur if ZETA between two non removable disks with identical partition tables to differentiate.this drive cannot be taken to the boot manager,as long as this is not solved,shall we continue?

all of these existing programs are in copyright matters protected. that copy of data and programs on other carrier media, is not permitted also in part.

OH, YES, it boots okay.SLOOOOOOWLY, as does ubuntu from CD.Its the only one so far to boot natively. I get 300 fps+ on the coffee pot.


the links are numbered 1,2,3,4,5,6,7 (.tiff) 1-5 and 6-7 are EXAMPLE numbers.server is up.doesn’t allow direct browsing.(THANK GOD)

found out 4.tiff was a duplicate file.

Ok, figured it out. In your previous post you stated they were named image1-7.tiff when they’re actually 1-7.tiff ( no image in the name ).


I’m going to look through the tiffs b/c I’m curious what you were getting.

For boot manager type “bootman” at command prompt. That’ll allow you to install it.

You can change the language to English in the LiveCD if you go to Preferences. Can’t remember what it’s called.

1.tiff - looks like it was writing the boot code to part1 but froze
2.tiff - tells the rest of the story; Error, failed to write b/c of device timeout
5.tiff - Haiku bootloader but nothing to boot from
6.tiff - copying Haiku image files/folders to Haiku1 partition ( actually good idea b/c then you may be able to get around the 250MB limit - better than dd’ing image )
7.tiff - makebootable -full Haiku1 but I see it references raw. I believe raw is the entire drive? Was there only a single partition b/c it usually refers to a specific partition /slave/0,1,2,etc. & not /slave/raw.

1.tiff was the closest to working b/c it calculated the partition offset.

Anyways, I’m sure you’ll get Haiku up & running on your drive using Zeta LiveCD. Too bad, I was hoping there was an easy way to do this through Linux but that doesn’t seem to be the case.

maybe if I reformat the system drive(to ubuntu).gonna be awhile before that happens again.

there is ONE partition(two if you look thru dos fdisk). raw is just the whole drive.
its not frozen, I captured the image too soon. when I write to the partition, it gives me errors.

THINK I have it now.made a new raw image with QEMU.
did the cp * …
did makebootable,(but I’ll upload this…) hangs QEMU on boot.(Like computer did yesterday)

re-tried makebootable referencing RAW drive and GUESS WHAT?

the new image boots HAIKU!!! :slight_smile:

it formats as correct size (512mb), makebootable seems to like it.BTW, makebootable IS SUPPOSED to write to the RAW drive.(I think)

will try to dd this to the ACTUAL thing in a few…

ZETA,maybe thru emulation.(and a little german) kicker keeps crashing and preferences panel, the one you mentioned, keeps crashing before I can make the changes.will try running it thru QEMU.maybe its my hardware.the boot kicker keeps giving me that ‘too close to beginning of drive error’ in german.

seems this is only way for now. ZETA Cd for those interested in on another page.I updated the links.



bootman is included with HAIKU.(in english no less).
to get that 2k freee… hmm…(work on that in a bit)

hmmm…things that make you go hmmmm…

got safe mode to work.loads okay in english now.AHHHH.nothing like a foreign language OS to wake u up.

Haiku and SENRYU:
stuck because floppy usb refuses to mount. pulled a make floppy script for both from ZETA.maybe i should mod it? its looking for hard wired floppy, i have none.
seems disk inside drive is at SCSI 0,2.

got BEOSMAX to work,without keyboard or mouse.(USELESS–who uses ps2 anymore?safe mode AGAIN…)


Here is an Idea if you want to boot it native on a standalone system and not a duel boot with any other loaders then the one haiku has.

Add it to a BartPE setup with Roadkils disk image as plugin there is one out there and then have the raw disk image used by that disk to add it to current disk and then reboot and it works.

Why isn’t there a bootable CD image for Haiku yet? That’s the biggest reason I don’t try it very often anymore. Until there’s a little more effort put into running it more easily on real hardware it’s just the little toy OS they run in emulators. The argument that it isn’t ready for bootable media doesn’t help bring new people to this project or keep old BeOS users like me excited about it. I just won’t jump through Linux and Emulator hoops. Sorry for being critical but the last time I got excited about Haiku was when I had a bootable Haiku CD that actually worked and I didn’t have to build it myself.

There will surely be a bootable CD once the alpha stage is reached.
The developers want that the people have a first good impression with the first release.
Even if we’re close to the alpha, it would be a bad idea to have an official release which leave a bad impression to normal users.