/bin/install: Invalid argument while trying to execute "make install"

Hi people out there using Haiku !

I’ve compiled both wget 1.19.5 and wget2 (v1.99.2 I guess, latest code from the repository) and it worked but when I tried to install them by typing “make install” I always got the same error:

 /bin/mkdir -p '/usr/local/include'
 /bin/install -c -m 644 wget.h wgetver.h '/usr/local/include'
/bin/install: cannot create regular file '/usr/local/include/wget.h': Invalid Argument
/bin/install: cannot create regular file '/usr/local/include/wgetver.h': Invalid Argument
Makefile:1438: recipe for target 'install-includeHEADERS' failed
make[3]: *** [install-includeHEADERS] Error 1

I know that /usr doesn’t exist in Haiku but when trying to install to /bin I got a similar error:

/bin/install: cannot create regular file '/bin/wget2': Read-only file system

Acording to the wget 1.19.4 recipe “make install” should be enough: https://github.com/haikuports/haikuports/blob/12b6b929a47ede7b8aeef1f291e8069490f751c8/net-misc/wget/wget-1.19.4.recipe

What is wrong? Thank you !

GNU Wget2 source code: https://gitlab.com/gnuwget/wget2

Configure the stuff like:
./configure --prefix=/boot/home/config/non-packaged

There is no /usr and the system folders are read-only. Check the guides for more info:

Or install wget from the depot. Or check, how wget compiled with haikuporter:

This method WILL NOT work without haikuporter. Check the HaikuPorts Wiki how to install and set-up haikuporter on your machine, and how the recipes working, and what runConfigure does.


Now our README includes information related to the compilation process under Haiku. Thank you @extrowerk !

1 Like