BeSpecific Disc Applications on PPC


#1

Hello, folks! I’m trying to see what there is in terms of applications for the PPC version of BeOS 5.0.3. So, I burned a few of the old BeSpecific CDs and have been trying to run a few of the included apps, albeit with no luck so far. Each application gives me a “missing symbol” error when starting it up. Is this a sign that it was built for x86, or am I just not installing/running these applications properly?


#2

The BeSpecific CDs are old, the first has software for DR8 and a few for DR7, and the last disc (Volume 6) for BeOS R4.
Volume 5 is for x86 only.
Try the software on Volume 6, but if you’re really curious about earlier stuff, you could install DR8 on your 8500, ah no, the CD on archive.org has been dumped incorrectly.
I can dump mine next week if you’re interested.
There’s a correct R4.5 though in the archive.


#3

I added to my repository the DR8 and DR8.3 discs (both have a DR8.2 readme on the disc, so not sure if they are what they’re pretending to be), and also the cover disc of the french issue of Macworld magazine from december 1997, which supposedly contains the PR1.2, but the disc only seem to contain just one track…
Pics of the discs:
DR8 http://shakti.trincoll.edu/~bjackson/IMAGES/BeCDbig.jpg
DR8.3 https://page.auctions.yahoo.co.jp/jp/auction/e237521841

Get them here:
https://mega.co.nz/#F!XgISkABI!4HUJmGU7AcPZvqd_JsOx9Q


#4

Thank you for the advice, but I’m having trouble getting BeOS to recognize the disc. When trying to mount the burnt discs. I tried burning BeSpecific 2, and Drive Setup says the disc is unreadable. #6, however, is seen as “multisession”, and also does not mount. Is there another way to get the CD to mount or get these programs onto the hard disk?


#5

The filesystem was changed at some point between the PR2 and R3 revisions of BeOS PPC (I think) so old discs can’t be read by newer versions of the system.
Not being able to mount the BeSpecific 2 disc is a result of that.
With the #6 disc in the drive, what happens if you do a right click on the desktop on go to the “mount” submenu? Does it show the disc?


#6

The SCSI CD drive is not seen in the mount menu - only in the Drive Setup, where it also will not mount. Oddly, the first CD in the BeSpecific set mounts and reads just fine, even though I can’t use any of the programs on it. Is that because the x86 version of BFS didn’t change in that same time frame?


#7

That’s weird. I redumped the disc with Imgburn and the .bin is identical as the one I uploaded already, which was done with Isobuster, the .cue has the same time stamps but one extra line for track2 index 00, I uploaded that cue file at the same place, get it and reburn the disc perhaps.
x86 and PPC version can’t read each other filesystems.


#8

BFS was tied to the processor architecture. A PowerPC would have BFS in Big Endian format and x86 would have BFS in Little Endian format.

For x86, there’s a filesystem addon that will allow reading of Big Endian BFS,


#9

I’m burning it in Toast Titanium on OS X, and that image you hosted still doesn’t work when burned… :frowning:


#11

I’m still not able to get this disc to mount. Has anyone gotten the applications off this disc and hosted them anywhere? Or is there any reliable place to download PPC BeOS applications anymore?


#12

It’s a mess, but you’ll find some ppc apps here:
http://pulkomandy.tk/~beosarchive/unsorted/


#13

You can use the search function from the homepage at http://pulkomandy.tk/~beosarchive . It’s a simple filename based search but maybe more efficient than digging through the directories if you look for something in particular (it does search the “unsorted” directory).


#14

Give me some time and I’ll dump every disc into large tar archives, all of the software on them was available on the official Be ftp at some point I assume, being freeware and shareware only.


#15

Good to know that it does search in “unsorted”